10

Since I updated to 10.12.4, whenever I go to a website playing video (tested on YouTube, Vimeo and others), Safari 10.1 takes a few seconds to start the video and then plays it in fullscreen, whether I want it to be fullscreen or not.

This only happens in my main user account, not in my second test user account. I already tested disabling all extensions and launching Safari with shift, but so far, no luck.

Any ideas why that happens? Is there a way to reset Safari or something (without losing my iCloud bookmarks)? I'd like to avoid having to create a new user account and move everything over.

9

STOP YOUTUBE, ETC. VIDEOS FROM OPENING FULL SCREEN

Note:

If you don’t see DEBUG as an option on the Safari menu at the top of the screen, first enable it as indicated in the next set of instructions below ("HOW TO HIDE OR UNHIDE DEBUG ON THE SAFARI MENU"), then return to these instructions to complete the process.

If DEBUG already appears as an option on the Safari menu, simply do as follows:

  1. In Safari, click the DEBUG option at the top of the screen in the Safari menu.

  2. Click MEDIA FLAGS.

  3. Uncheck DISALLOW INLINE VIDEO.

  4. Now the videos should play as normal without opening full screen in the future.

HOW TO HIDE OR UNHIDE DEBUG ON THE SAFARI MENU

To Enable Safari's Debug Menu:

  1. Launch Terminal, by clicking Finder (on the Dock), then clicking APPLICATIONS, then clicking UTILITIES, then clicking TERMINAL.

  2. Enter the following command line into Terminal by copying it and pasting it (triple click on it to select the entire line):

defaults write com.apple.Safari IncludeInternalDebugMenu 1

  1. Press the RETURN key.

  2. Launch (or close then relaunch) Safari, and you will notice the new Debug option appears in the Safari menu at the top of the screen.

To Re-Hide Safari’s Debug Menu:

  1. If for any reason you ever want to re-hide DEBUG on the Safari menu, follow the same procedure but with the following command for Terminal instead.

  2. Launch Terminal, by clicking Finder (on the Dock), then clicking APPLICATIONS, then clicking UTILITIES, then clicking TERMINAL.

  3. Enter the following command line into Terminal by copying it and pasting it (triple-click on it to select the entire line):

defaults write com.apple.Safari IncludeInternalDebugMenu 0

  1. Press the RETURN key.

  2. Launch (or close then relaunch) Safari, and you will notice the Debug option has disappeared from the Safari menu at the top of the screen.

  • Thanks! Describing the whole process with the Debug menu makes this a much better answer than mine. – Alex Wally Feb 7 '18 at 4:56
5

Turns out this was not a bug, it was a feature I had actually enabled myself.

Thanks to Bob's answer, I realized it was a setting - it's hidden in the Debug menu → Media Flags and called, appropriately enough, "Disallow inline video". One day I tested it out because I thought it would only disable unwanted ad videos, and the next day I of course forgot that I had enabled it. So if anyone finds this and has the same problem, check that setting.

  • Ah. Well, now that you know what it was, you still have a backup of your old preferences file! Just run that revert command, reopen Safari, and fix the setting. – Bob Apr 10 '17 at 14:19
  • Also, if you want to un-accept my answer and re-accept your own (better) answer, I'm totally cool with that. – Bob Apr 10 '17 at 14:19
  • Okay, I'll do that! Some websites actually advocate that setting, so who knows, maybe other people will get the same problem. - I can accept my own answer in 2 days. – Alex Wally Apr 10 '17 at 14:24
1

Try clearing the Safari preferences. Close Safari and run this command in Terminal:

cd ~/Library/Preferences; mv com.apple.Safari.plist +com.apple.Safari.plist

This will move the existing preferences file aside and force Safari to create a new, blank one with all preferences set to default. If that doesn't solve the problem, here's a command to put everything back the way it was and restore your preferences:

cd ~/Library/Preferences; mv +com.apple.Safari.plist com.apple.Safari.plist; rm +com.apple.Safari.plist

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .