12

I don't like an unnecessary permanent open port from the Dymo Label Webservice when I use the Dymo Application every few weeks.

Is it possible to remove the web service and still use the Application to print a label every now and then?

All I found on the web were instructions to remove the Dymo software completely, which is not my intention.

I have installed the newest version 8.6.1 of the Dymo Label software.

21

Method 1: Unload Launch Agent.

The Dymo Label Webservice is started by a launch agent while booting (or better: logging in with a user). You should be able to simply unload the related launch agent:

sudo launchctl list | grep dymo #check if agent com.dymo.dls.webservice is loaded
sudo launchctl unload /Library/LaunchAgents/com.dymo.dls.webservice.plist

You may have to use the force switch: ... unload -w ....

Method 2: Set RunAtLoad to false.

If you are not successful you can try to change the RunAtLoad key in /Library/LaunchAgents/com.dymo.dls.webservice.plist with

sudo nano /Library/LaunchAgents/com.dymo.dls.webservice.plist

from

<key>RunAtLoad</key>
<true/>

to

<key>RunAtLoad</key>
<false/>

Reboot and check if your Dymo label printer also works without the open port of the webservice.

| improve this answer | |
  • 1
    I edited /Library/LaunchAgents/com.dymo.dls.webservice.plist. Now the webservice doesn't start any more and printing still works. Thanks :-) – Gerd Castan Apr 11 '17 at 18:08
  • Editing /Library/LaunchAgents/com.dymo.dls.webservice.plist worked beautifully. Thanks! – Joshua Pinter Apr 4 '19 at 14:29
  • Method 2 is beautiful. Thanks. – Vic Jang Dec 14 '19 at 18:35
  • 1
    It's generally safer to use the defaults command rather than an editor when making changes to property lists; sudo defaults write /Library/LaunchAgents/com.dymo.dls.webservice.plist RunAtLoad -bool false – macaco Dec 17 '19 at 9:58
2

Just delete it, or block the port using a firewall and see if it still prints for you. If not you might have to reinstall the application (or stop blocking the port) to get it working again.

I use Little Snitch as an easy way to block particular connections. Someone smarter than me could probably tell you how to configure the built in firewall to block the connection for free, but you could use the free trial of Little Snitch to at least see if the software keeps working when you keep it from phoning home.

| improve this answer | |
1

Download the Dymo installer from http://download.dymo.com/dymo/Software/Mac/DLS8Setup.8.7.3.dmg

  1. Run it.
  2. After the accept license step you will be on the Installation Type page, click Customize.
  3. Check the box to uninstall and uncheck the box to update the Web Service.
  4. Run the rest of the installer.
  5. When it completes run the installer again.
  6. This time on the Customize page uncheck the box to update the Web Service and complete the installation.
| improve this answer | |
1

Turns out it's really easy. I got this from Dymo customer service:

Go to: Macintosh HD/Library/LaunchAgents/ and remove the file called: com.dymo.dls.webservice.plist.

Then restart. The local printer still works, and the online service is gone.

I expect that if you do want to use the online service, just save that launch agent pref file somewhere else on your hard drive, and replace it in the LaunchAgents folder when you want to reactivate it.

| improve this answer | |
-1

Open your startup options and disable it from Startup.

| improve this answer | |
  • 2
    Can you expand your answer to explain how to get to ‘startup options’? – grg Jan 17 '18 at 14:41
  • It's not in the list of startup items within System Preferences – errant.info Jan 30 '19 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .