Can't enable iCloud Drive on OS X Sierra. Going to Sys. Preferences > iCloud , can enable every feature, but not iCloud Drive. Can't enable it and icon has a fade out effect. Tried to log out and login again - didn't worked.

iCloud settings

What could be the problem? My Mac was issued me by my company - could they block that feature?

macOS Sierra 10.12.5 Beta (16F43c)

  • Why do you run a Beta Version? This could be a side effect caused by 10.12.5 Beta.
    – howdytom
    Feb 15, 2018 at 13:34

4 Answers 4


In case this is your company's computer, it could have been deactivated through a management software, like jamf:


  • This might have been better as a comment. Alternatively, you could consider expanding your answer to explore other possibilities and any potential solutions/workarounds that would remedy the OP's problem.
    – CJK
    Feb 15, 2018 at 13:32
  • Actually, @xanderiel is right. But do you have any idea how to unlock this policy? Feb 20, 2018 at 9:06
  • Agree it could also have been a comment. Regarding the OP's question: in case it's regulated through jamf this should be nearly impossible to circumvent. jamf's core business is to enforce company policies so "worthless peons" cannot get around it. It's closely tied to the OS anyway. But, you might simply talk to your corporate IT team to see if there's a way around it.
    – AlexGrafe
    Feb 21, 2018 at 11:17
  • while you will not be able to modify jamf's policies, you can simply remove jamf itself from your laptop. Dec 11, 2019 at 14:45

These ports need to be open on your company's firewall/security appliance to allow iCloud in general:

To allow iCloud to function, Apple has a list of ports which need to be allowed for iCloud to function on your client devices. The ports used by iCloud are:

TCP 25

TCP 80

TCP 443

TCP 587

TCP 993

TCP 5223

See this Meraki page for more details. Your company's IT group should be able to tell you if these ports are blocked. Which specific port blocks iCloud Drive is not clear.


This is strange indeed. Have you tried booting in Safe mode?

Start up while holding the left shift key.

  • didn't help at all. At least I know about the safe mode - thanks! Apr 10, 2017 at 21:46
  • 1
    iCloud is still not available. I think it was "removed", as I can't find iCloud path lurking through terminal: $ cd ~/Library/Mobile\ Documents/com~apple~CloudDocs -bash: cd: /Users/dmitry.mihailov/Library/Mobile Apr 11, 2017 at 7:50
  1. What happen when you try to access via Terminal? Access iCloud Drive

  2. Try to access the same via www.icloud.com

  3. What about your iPhone? Same issue

  4. Try to sign out and sign in again.

  5. Anything going on with your Search Domains? Add Search Domains

  • 1. output 2. There are only my photos from iphone and nothing from Mac. 3. iPhone works fine with iCloud. 4. Tried - no results. Will try with safe mode. 5. Search domains - how are they involved here? Apr 10, 2017 at 21:23
  • 1. output: $ cd ~/Library/Mobile\ Documents/com~apple~CloudDocs -bash: cd: /Users/dmitry.mihailov/Library/Mobile Apr 10, 2017 at 21:37
  • did you use to pay for more storage and than stop to pay apple? example did you request more GB previously ? I will also try getsupport.apple.com Apr 10, 2017 at 23:16
  • I got to the support, they've took remote control of my Mac... and no results. I think may it's because of Beta OS I have installed. Jun 2, 2017 at 7:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .