1

I'm trying to run Wine with x11 driver (because some apps only work with x11 driver). I had installed XQuartz and it works and runs xterm.

However, when I run Wine, it outputs:

err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
err:winediag:nodrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.

I have libX11.6.dylib in /opt/X11/lib/libX11. Specifying it with DYLD_FALLBACK_LIBRARY_PATH or DYLD_LIBRARY_PATH environment variables when running Wine does not have any effect.

Applications bundled into .app such as Inkscape also don't work, but Inkscape does not output any error messages, just windows don't appear.

What can I do so X11 apps will be able to use XQuartz?

Mac OS 10.12.4, XQuartz 2.7.11.

  • How are you specifying DYLD_FALLBACK_LIBRARY_PATH or DYLD_LIBRARY_PATH? Also SIP will block these. Try using WineSkin for packagine Windows apps - it wraps Wine and the App and so advoids these issues – user151019 Apr 9 '17 at 19:09
  • DYLD_FALLBACK_LIBRARY_PATH=/opt/X11/lib WINEPREFIX=… wine …. Wineskin works, but seems that it bundles its own XQuartz. – kolen Apr 10 '17 at 12:46
  • Which file are you setting them in and how are you calling the wine app - ie so that we can repeat your setup – user151019 Apr 10 '17 at 13:20
  • Created shell script: gist.github.com/kolen/b9b0a142a7e46fa9c97dbdde461823d5 – kolen Apr 11 '17 at 15:48

You must log in to answer this question.

Browse other questions tagged .