1

I have configured an SSL web site using the macOS Server app (version 5.3). When I examine the Apache log, I see this message (twice):

 [ssl:warn] [pid 4120] AH01916: Init: (mydomain.net:443) You configured HTTP(80) on the standard HTTPS(443) port!

I have not made any manual modifications to the Apache config file. I tried deleting the site, then stopping and restarting the web server, and finally re-adding the site from scratch, but the warning continues to show up in the log.

What is wrong and should I care?

  • Any solutions found? – JBis Sep 13 '18 at 2:56
  • No, I didn’t. Still waiting for a good idea. – not2savvy Sep 13 '18 at 12:06
  • Hmm. Tried removing and re-adding didn't work. Will look into config files see what I could do but it doesn't seem to effect anything. – JBis Sep 13 '18 at 12:21
  • Yes, in fact, I decided not to care, but still hoped someone had solved it. – not2savvy Sep 13 '18 at 12:23
-1

Check the configuration file of your website for "SSLEngine off". In my case, this setting had been changed by the upgrading process. Changing that line to "SSLEngine on" solved the issue.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Which configuration file would this be and where (path) would a user find it? – nohillside May 2 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .