I'm trying to rename a folder which I've kept in iCloud.

Mark the folder first and then press return as normal in Finder does not work.

I've tried to google some solution but haven't found anything which has worked.

Are there no way to accomplish that task?

Why is that made that difficult? I really got no idea ...

I'm using a Mac Mini with macOS Sierra.

UPDATE I have now tried to rename the folder from an iOS device (iPhone).

There it is similar. I get only options for moving and deleting the folder after selecting the folder.

No idea ... Why?

  • What folders are you trying to rename? Works fine for me. You can only rename user-created folders, not application-created ones like Pages, Automator, etc. – user11633 Apr 9 '17 at 13:40
  • Just a complete normal folder with files into it. Created with Finder. I have got no idea why it isn't possible. – mizech Apr 10 '17 at 5:51

Try renaming your folders from the command line, by typing the following into Terminal:

cd ~/Library/Mobile\ Documents/com~apple~CloudDocs
mv "oldFolderName" "newFolderName"
  • That have worked like charm. Awesome. Thanks a bunch. – mizech Apr 10 '17 at 17:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .