1

This is a very frustration issue and I am banging my head against the wall.

I have an old iMac Intel 21.5" EMC 2389 iMac I salvaged from my parents and the drive failed. I added a new 1TB WD drive to replace the old 500GB WD drive:

https://www.ifixit.com/Guide/iMac+Intel+21.5-Inch+EMC+2389+Hard+Drive+Replacement/6284

Tried to do a clean install of OS X and it kept going into an installer loop after the first install reboot (would go back to the start and ask you what drive to install to etc.).

I finally figured out that the newly formatted internal hard drive is not bootable despite me partitioning and formatting it with the GUID Partition Map. If I select the drive in Disk Utility and click the info button the drive is listed as bootable = no.

So the installer plugs away, installs the first wave of files then reboots expecting it to boot from the target but it can't so it goes back to the installer USB stick again.

  • Tried the install from the internet. It installs the installer data 3-4 GB worth but the iMac won't boot and continue the install. I mounted it via FW target disk mode and Disk Utility says that it IS bootable. Suspecting I have a hardware failure issue with the iMac. – Dan Tappin Apr 9 '17 at 5:41
  • I experienced the same problem. My disk failed and after replacing it with an old disk discovered the importance of this 'bootable' flag. I wonder if bootable correlates to the "system integrity protection supported" flag. Unfortunately, I can't find any additional information on this. Did you solve your problem? – Josh Nov 25 '17 at 5:16
1

Why are you installing from usb?

I recently replaced a hard drive in a 2008 mbp with samsung 850 evo. Using Target Disk mode, connecting mpb to my imac via 1394b/tb, i used the online restore to write the install image to the mbp after using the same connection with DiskUtil to partition journaled mac format.

Despite what the interweb blathering to the contrary claims this works as designed.

  • The issue is not USB vs Firewire install. I can't make the the internal hard drive bootable. I actually tried via target disk mode and the same thing happened. – Dan Tappin Apr 8 '17 at 22:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .