0

I have two Macs, both running Mac OS Sierra. I can ssh from the laptop to the desktop and use Apple's screen sharing to view the desktop's screen from the laptop. I cannot mount the desktop's disks on the laptop. I have Sharing turned on, both AFP and SMB, but I cannot connect via either. I've tried connecting to the desktop via smb://, smb://.local, and directly by its local IP address (and the same for afp://). ssh <hostname>.local works, so it's not a DNS resolution issue.

The specific error I get is:

The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

Edit: I should mention that when I try to connect by selecting the machine through the Finder sidebar, it doesn't connect, and clicking "Connect As" fails before getting to the password screen.

  • Have you tried sharing with SMB disabled? – IconDaemon Apr 8 '17 at 18:27
  • I have not, actually. You're recommending I try just AFP? – CajunLuke Apr 10 '17 at 14:28
  • Yah. SMB is for Windows machines to connect to the server. – IconDaemon Apr 10 '17 at 16:02
  • In response to your comment to user2720970's answer: are you trying to mount Macintosh HD, or just folders contained within? – IconDaemon Apr 10 '17 at 16:07
  • I'm actually trying to mount an attached disk, I was able to do this a few months ago, and I was presented with the options for Macintosh HD and the attached disk. – CajunLuke Apr 11 '17 at 14:16
1

Make sure you have the user enabled in sharing (File sharing/options) Then try ssh localusername@hostname.local

  • ssh already works; I want to mount the hard drive on my laptop over the network. – CajunLuke Apr 10 '17 at 14:28
  • sudo mkdir /Volumes/SHARENAME; sudo mount_afp afp://localusername: localusername@hostname.local/SHARENAME /Volumes/SHARENAME – user2720970 Apr 11 '17 at 10:11
  • I ran $ sudo mount_afp afp://user@hostname.local/diskName /Volumes/diskName/ and got: "mount_afp: AFPMountURL returned error -1069, errno is -1069". – CajunLuke Apr 11 '17 at 14:55
  • Thanks for helping, I found out my problem was my own stupid configuration settings. I gave you an upvote as your answer is more likely to be of use to people. – CajunLuke Apr 12 '17 at 2:55
0

The problem is my fault; I'd set up File Sharing not only in Sharing preferences like normal, but also in the Server app, and I'd set an access restriction so that only clients with 172.16.*.* IP addresses could connect and my network is configured as a 192.168.*.* network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .