0

Yesterday I had my first photo session with my new Fujifilm X-T2. Today, I inserted the SD card on my mac, opened Photos (Sierra) and saw all the pictures I took (raw). I proceeded with the import, and all seemed ok.

But even If I can see the thumbnails for all the pictures imported, when I open some of the photos I just get an exclamation mark.

I've tried importing/deleting multiple times, I've tried rotating,unrotating. Nothing. Apparently Photos doesn't like some of the pictures I took :(

Any suggestion?

2

The problem is your camera is too new! Apple Photos does not yet support RAW files from the Fujifilm X-T2. Apple should release an update that will add this support, but I could not tell you when that might happen. For the full list of supported camera RAW formats, see this site.

3
  • Edit: just released I added the wrong link! Link has been corrected
    – NoahL
    Apr 8 '17 at 16:38
  • Thanks Noah. That's very dissapointing, but I'll have to wait...
    – fazineroso
    Apr 8 '17 at 16:51
  • @fazineroso if you're looking for a workaround solution, Adobe Camera Raw v9.6.1 (Photoshop and Lightroom) supports X-T2 RAW.
    – NoahL
    Apr 8 '17 at 16:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .