7

I just got a MacBook Pro, and different from my iMac is that I'll be using the lock-screen much more on this one.

I noticed that in the upper right corner of the lock screen, the time is shown, but it is in 12-hour mode with AM/PM indicators.

I guess this is some remnant of the machine having been configured to use english language as the main language (I'm a developer, I don't want to have to fight with badly worded Norwegian translations of error messages on google).

I have configured my main user to have normal Norwegian formats for everything, but I guess that on the lock (and possibly on the logon screen as well?) screen, there is some kind of global system-wide configuration in use.

So, can I:

  1. Configure the lock screen (or the system wide configuration) to use 24-hour clock?
  2. Remove the clock altogether?
  • 1
    I know this is nitpicking, you can tell that I get along with my MBP if this is the kind of things I'm worried about :) But still... AM/PM indicators annoy me (mostly because I've never taken the time [no pun intended] to learn them properly) – Lasse Vågsæther Karlsen Oct 16 '11 at 15:25
  • This definitely sounds like a bug (I just repro'd it on my computer). Please file a bug report at bugreport.apple.com – Dave DeLong Oct 16 '11 at 16:01
7

Since at the login window (and the lock screen) your user is not logged in, you´ll have to edit the global preferences:

sudo defaults write /Library/Preferences/.GlobalPreferences AppleLocale en_GB

and:

sudo defaults write /var/root/Library/Preferences/.GlobalPreferences AppleLocale en_GB

and then do a reboot. This fixed it for me (and I hope, Apple fixes that sooner or later). :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .