0

I've had this problem for several days now. The Application-Switcher [cmd-tab] does not show the correct icon for my application, it shows a generic icon. Does anyone know how to fix this?

See attached image:

Screenshot of Command-Tab Switcher

The Terminal is supposed to look like this:

enter image description here

This doesn't happen every time, only every once in a while. It happens with random applications, not just Terminal.


I found where Terminal through Finder (to make sure the app shows up with the proper icon in finder) and then I closed the open Terminal app and opened a new Terminal session by double-clicking through finder instead of using spotlight.

Now I get the correct Icon:

Screenshot of Application Switcher

If I get the "generic" Icon again, I'll come update. If it works for 24 hours, I'll come back and post the answer.

1

Upon re-reading your question after your edit I see you're comfortable with using Terminal, so I've added a second potential solution for this. You do not need to try these in any particular order - try one first and if the issue returns, then try the other. Option 1 sometimes only works temporarily, but Option 2 requires entering commands in Terminal.

Option 1: Reset and restart the Dock

One remedy is to reset and restart the Dock. However, in doing so, you will need to re-add any non-default icons to your Dock. (I usually find it's a good opportunity for people to start afresh and only add things as they actually use them).

So, if your solution doesn't pan out, you can reset and restart the Dock as follows:

  • Go to Finder
  • Press and hold the option key down
  • Now go to the Go menu
  • Select the Library option to open the User's Library folder. You can let go of the option key now.
  • Go to the Preferences folder (i.e. within the Library folder)
  • Find and move the com.apple.dock.plist file to the Trash
  • Now open Terminal (usually located in Applications > Utilities)
  • Enter this command killall -KILL Dock
  • Press enter

This should resolve the issue - but remember you'll need to re-add some apps back to the Dock.

Option 2: Reset icon cache

If the first solution above doesn't work (or it only works temporarily), you can try resetting the icon cache.

  • Launch Terminal (usually found in the Applications > Utilities folder)
  • Enter the following three commands, one at a time:

sudo find /private/var/folders/ \ -name com.apple.dock.iconcache -exec rm {} \;

sudo find /private/var/folders/ \ -name com.apple.iconservices -exec rm -rf {} \;

sudo rm -rf /Library/Caches/com.apple.iconservices.store

Let me know how you go.

  • Firstly, Thank you for responding - So to be sure, the problem I'm experiencing is in the Application Switched, not the Dock per-say... I figured you understood that - I just wanted to be sure. This isn't about the icon in the Dock, it's about the icon in the "alt-tab" (command-tab) switcher. I'll be sure next time I see this happening to look at the icon on the Dock and see what it is. – Jeremy Iglehart Apr 9 '17 at 16:18
  • Thanks for the feedback. I've updated my answer to include a second option. Originally I had started working on it before your edit (sometimes I draft my answers offline) and I missed you were obviously very comfortable with using Terminal. Hope this helps. :) – Monomeeth Apr 9 '17 at 21:22
  • Excellent answer. It seems to have done the trick - I first tried the Icon Cache solution you mentioned, and it didn't seem to completely solve my problem. I've also done resetting the dock prefs. That seems to have made it stick. Or the combo worked. Thank you very much. – Jeremy Iglehart Apr 14 '17 at 1:00
  • So, the problem in my case is persisting. I'm feeling like something is corrupt. I might do a complete system wipe... I'm noticing other weird ticks here and there (mostly related to Microsoft's Office). Strangely it feels like my system is behaving the way my old Windows XP machine felt when it had a virus. But I don't think that is the case. Something is off though, maybe more than one thing. For example, my system is forgetting what applications are the default application for opening various files. The "Open With" option menu item takes forever to come back, and general weirdness. – Jeremy Iglehart Apr 15 '17 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .