1

I have just changed to Sierra - 10.12.4

Some apps (e.g. Aquamacs, Moneywell) in the Dock when you start them do not get a mark saying they are running but create a new icon that represents the running instance. This icon seems to have as its app one under /private/var/folders but with the correct app name not one in /Applications

Why is this happening and how can I get things back to how previous OSX versions worked.

  • Would you be able to specify one such app that is behaving thusly? It's probably that the app has a wrapper that then launches an executable and you would need the vendor to change the app - but rather than shoot off guesses - could you narrow down with an edit one such app? – bmike Apr 8 '17 at 13:37
  • This is because the app is quarantined. De-quarantine the app by running sudo xattr -d com.apple.quarantine -r "/Application/SomeApp.app" – mspasov Apr 8 '17 at 18:38
  • @mspasov That is basically correct - the command should not have a -d. If you write that up as an answer together with the reasoning/documentation. That does lead to another question why have I just started getting the issue, in the last week I have upgraded the OS and my browser Vivaldi – Mark Apr 8 '17 at 19:40
  • @mark Without -dr the flag will not be removed, it will only print the flags. Are you sure? – mspasov Apr 8 '17 at 19:50
  • @mspasov the exact command you say gave an error "xattr: No such file: -r" amnd -d on its own seemed to have worked for the second app – Mark Apr 8 '17 at 19:59
1

The issue is caused by Gatekeeper. It uses "path randomization" to run applications, until the user moves the app in it's final destination (/Applications for example). This causes the app to be run from /private/var/.. and Dock treats this as a new app.

To remove the quarantine attribute execute (removes recursively com.apple.quarantine):

sudo xattr -dr com.apple.quarantine /Application/SomeApp.app

Recursion (the -r flag) may be needed for apps that contain helpers.

To list the current attributes for an app execute:

sudo xattr /Application/SomeApp.app

or

ls -l@d /Application/SomeApp.app

Sources:

On Gatekeeper and the Lifespan of Little Snitch Rules

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .