1

The wifi is connected to my Mac but the internet isn't working. On my phone, it is perfectly fine.

I have tried:

  1. using a personal hotspot from my phone to my computer but the internet still doesn't work.
  2. in recovery mode, the internet works.
  3. Restarting Router (although I don't think the problem is there)

Any help would be much appreciated as I have a lot of work due :0 Thank you in advance!!!

Edit (links to wifi tab):

enter image description here

enter image description here

  • Can you post screenshots of all the tabs for your wifi connection under System Preferences? – jimmy0x52 Apr 8 '17 at 1:31
  • Ok hmmm once again the internet stopped working. Sba I call Apple help desk – Anurag Apr 9 '17 at 0:22
  • It's Wi-Fi, TCP/IP, DNS, WINS, 802.1x, Proxies, Hardware – Anurag Apr 9 '17 at 0:23
  • I don't need a list of them - I want to see a screenshot of each of their contents. Post them as an edit to the original question. – jimmy0x52 Apr 9 '17 at 0:24
  • 1
    See that DNS server - 192.168.0.1? Click it and click the minus sign at the bottom. You'll see it turn from black to grey. That will fix your problem – jimmy0x52 Apr 9 '17 at 0:37
1

Typical advice I give in this situation is to check your TCP/IP Settings under the wifi connection in your Network controls in System Preferences. Make sure you're using DHCP and no DNS servers are hard coded. Also make sure you don't have some kind of proxy software or VPN running on your computer.

Edit: try connecting your phone via USB and choosing that connection when you turn on hotspot and see if it works

Edit2: original poster posted a screenshot showing a hard coded DNS server. I recommend clicking on all hard coded DNS servers, clicking minus, and removing them.

edit3: the other issue may not be the wifi, but the modem to your internet provider.

  • There is no VPN on ATM and under my Configure IPv4, I'm using DHCP. There is no DNS hard coded severs I believe – Anurag Apr 8 '17 at 1:05
  • It works when my phone is connected via USB – Anurag Apr 8 '17 at 1:24
  • Definitely a config issue with your wifi network connection in settings. – jimmy0x52 Apr 8 '17 at 1:25
  • I have tried all way but nothing has resolved it. It works fine in recovery mode but any time else nothing. Any thing else I can do? – Anurag Apr 9 '17 at 5:04
0

Try the following:

  1. Open network preferences.
  2. Select your WiFi card on the left.
  3. Click "Advanced"
  4. Click "Proxies" tab. 5.Enable "Automatic Proxy Configuration"
  5. Close Network Preferences
  6. Quit Safari.
  7. Reboot your Mac and try again.

You must log in to answer this question.

protected by Community Jan 22 '18 at 19:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .