After about 3 weeks. I plugged in again into my MacBook and left it there. After more than an hour I came back and the drive showed up on my Mac again. (So somehow the problem got fixed.)

I ran First Aid on Mac's Disk Utility. It says the drive appears to be OK. So I don't know what fixed it exactly.


When I plug my WD Passport Ultra 4TB external hard drive WDBBKD0040BBK-0A (with 2TB of family photos) into my MacBook Pro it has fast flashing of light and can't be mounted. It can be read on a Windows laptop (after Windows automatically fixed an error). I tried opening up Disk Utility on my Mac, but it just spins forever trying to mount the external hard drive. Nothing ever shows up on Disk Utility.

How it broke:

The WD Passport Ultra was plugged into my MacBook on battery. I was not actively reading or writing to the external hard drive, but it did have a list of directories open (no individual photo files, but just the directory names). The battery ran out.

When I charged up my Mac again it says that the disk was not ejected properly. Ever since that my WD hard drive has the flashing problem and can't be mounted on my Mac. I tried changing the Mac laptop, changing the USB cord, same problem.

I then plugged in my WD hard drive to a Windows laptop. It says that it detected an error and had the option of automatically fixing it. I clicked "Start" and let it ran, but it didn't have a progress bar and just had a "Cancel" button. After running for 3-5 minutes, my mom came in and unplugged the external hard drive forcefully (I yelled at her for doing that). We tried plugging it into the Windows laptop again, and my files and photos could be read!! But it still can't be read on Mac and has the flashing problem.

Why is it like this? What is broken? How can I test what is broken?

I'm asking because I have had accidentally unplugged other WD external hard drives without ejecting in the past while not writing data, like in this case, but the drives never broke. What is up in this case?

I'm curious if this is something that happens a lot or if it's just a less durable hard drive I got. Because I'm at a point where WD's warranty can give me a new drive to replace it, or I can fix this drive myself. (I have copied the photos out to a new drive on a Windows machine.) Because if it is something that happens with the same frequency in all drives, shouldn't I just fix it?

What is the best free software program on Windows that might potentially fix my problem? Mac programs are good too if they can actually access it since my Mac can't even mount it.

  • 1
    What do you get when you plug in the WD disk and issue the command diskutil list in Terminal? Please post the output to your original question
    – Allan
    Commented May 4, 2017 at 1:29
  • Please check out the answer here -apple.stackexchange.com/questions/147869/…
    – Jash Jacob
    Commented May 4, 2017 at 4:25
  • is the WD disk formatted in NTFS? Or (ex)Fat?
    – LexS
    Commented May 6, 2017 at 18:45
  • It is in exFat.
    – Melissa
    Commented May 6, 2017 at 19:03

9 Answers 9


This happens because OSX "forces" a disk check/repair in the background before mounting the drive (since it was ejected improperly), so it will simply appear to not be mounting until that completes. It seems it was fixed for you when you let the check complete--- A quick way to "fix" this is to manually force quit the fsck process from activity monitor.

  • 1
    Thank you. This allowed me to recover files and fix the drive. Commented Jul 4, 2020 at 18:40

You can try the following solution.

In Terminal use the following commands:

diskutil list

Find your WD HDD identifier.

diskutil unmountDisk /dev/disk*
diskutil eject /dev/disk*

Replace * with your version

After that, you should be able to mount the HDD successfully.

  • You absolutely saved my life! Thank you so much!
    – Joel Hager
    Commented Jul 13, 2020 at 2:37
  • This worked for me as well. I believe that I unplugged a Time Machine disk that was not fully ejected and then it was left in a state of limbo the next time I went to use it. I also found these commands helpful. diskutil verifyDisk /dev/disk3 diskutil verifyVolume /dev/disk3s1 diskutil verifyVolume /dev/disk3s2 Commented Sep 21, 2021 at 11:25

As you have backed up the photos on the windows machine, you should try to use disk utility to fix your drive. There might be a volume mounting error or a format error, which can be fixed by using a function in disk utility called "first aid".

On your Mac, spotlight search for disk utility. It should show up. When it opens you should see a column on the left with all your disks listed there.

Here is how it will look

As you can see, this column has both internal and external drives listed there. Be extremely careful, do not tamper with the internal drives. Go over the list very carefully and select your external drive. It should be fairly obvious which one it is. In your case it should be labeled as something similar to WD passport ultra. If not, you can look at the storage capacity and check if it matches with your disk's (here, 4TB).

Next you need to run first aid. A self explanatory button placed towards the start of the row on the top says first aid. Click and let the magic happen! If it doesn't start right away, you may have a different version of macOS. In the case of this, click on verify the disk. Next, click on repair.

While doing this, please make sure no one yanks the cable out because that will be very, very bad.

If these situations occur:

  1. You see the outputThe volume "diskname" appears to be OK., but the problem still isn't fixed


  1. You see the output Scan complete. Problems were found, but Disk First Aid cannot repair them.

then you can try to install and use DiskWarrior or try other solutions given on this thread. You could also try reformatting the disk, the steps for which I can edit in later.

@jksoegaard's method looks promising too.

Good luck!


At first i tried to run First Aid on Mac's Disk Utility. But it didn't work. I unplugged the WD external, shut down my macbook pro, restarted it again,ran First Aid on Mac's Disk Utility again and finally it worked! It took about 5-6 min and my hard drive showed again :)

  • Welcome to Ask Different! This does not provide an answer to the question & appears be merely confirmation that one of the other answers worked. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – Tetsujin
    Commented Dec 18, 2017 at 11:35

A good idea would be to run the disk check in Windows to completion.

Plug in the drive, right click the drive in Explorer, select Properties, and then in the Tools tab you'll find "Error-checking". Click "Check Now" and let it scan the whole drive fixing any errors it finds.

  • Will it damage or change any photos?
    – Melissa
    Commented Apr 6, 2017 at 21:07
  • @Melissa Potentially, if it finds problems that you let it fix. The risk is very small, normally no data is disturbed. If you're worried about this scenario, take a backup before proceeding.
    – jksoegaard
    Commented Apr 7, 2017 at 18:19
  • The OP is asking about a Mac disk. You can't mount a Mac disk on Windows without doing extra work. And "take a backup before proceeding" is not very helpful, because the OP can't mount the disk to do anything! Catch-22. Commented Jun 21, 2020 at 20:42
  • Try looking at the question again - the question specifically says that the disk mounts on Windows without doing anything special. The disk in question is not a special “Mac disk”, but rather comes from factory formatted with the Windows NTFS file system. When you buy such a disk, you can just format it with any file system you would like - APFS, HFS+, ExFAT, etc.
    – jksoegaard
    Commented Jun 21, 2020 at 21:41
  • Regarding backup: the suggestion is actually very helpful and the correct thing to do. Contrary to what you seem to suggest, you can indeed backup a disk without mounting it first.
    – jksoegaard
    Commented Jun 21, 2020 at 21:42

I tried all the above, stressed for one afternoon, and then, from disk utility, clicked on the blue eject button on the top of the dialog box. Didn't ejected, but when I clicked then on the unmount and mount button. It mounted and appeared in my finder! ouf!


I had the same issue and went to the disc utility and did pretty much what Haroon, above, did-clicked on the eject button. It said it could not eject because the files were being used, so I tried repair and it looked like everything was fine, so I hit eject again and it still wouldn't unmount. I then went out of disc utility. It still wasn't there in finder, but when I pulled out the USB and put it back in-there it was!!


For Macs, if your External Hard Drive is not showing up in Disk Utility. And you have ruled out damaged drive and cable. The next step you should try is using Terminal.

Search Bar: Terminal

  1. Type diskutil list, press enter

  2. Find the Name of your External Hard Drive, it should show up here if it is not damaged. The External Hard Drive name is the next line under EFI EFI. Example "Productivity", "Universal" etc.

  3. If name is Universal, Type diskutil mount Universal, press enter (instead of typing the name of the drive, you can also type in the identifier, eg. "disk3s1, disk2s1, etc")

The External Drive should show up on Finder or Desktop. Good Luck, hope that works for you.


The same happened to me... Here's what fixed the problem for me...

It was ejected improperly because my Mac went to sleep mode or shut down because the battery drained, so it will simply appear to not be mounted until that completes.

For the fsck process to complete, it may take as the amount of time relevant to the memory stored on your Disk. Please connect your Disk and allow it to sit for few minutes to hours.

It took me about 10-15 mins (My 1TB Disk was 250GB full and 750GB empty)

A quick way to "fix" this is to manually force quit the fsck process from activity monitor. (not recommended because you have to restore the disk [i think])

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .