3

I use an external usb mouse/keyboard when I use my Mac (and have been for some time without any problems). Since the C-Error 10.12.4 update, my Macbook Pro no longer allows me to set/save my Mouse Tracking Speed in the System Preferences and the mouse tracking speed is stuck on slowest speed.

When I open System Preferences, the mouse tracking speed slider is on ‘Slow’. For a moment after I pull the slider to a higher speed, the mouse speeds up but then immediately returns to the slowest speed, though the slider stays where I set it.

The slider stays at my setting until I exit the System Preferences, whilst the mouse moves as though it's set to the slowest speed. When I return to the System Preferences, after closing it, the mouse tracking speed slider is back to the ‘Slow’ setting.

Moving the slider again repeats what I described above.

I have tried using defaults write -g com.apple.mouse.scaling 8 but that has no effect after logging out and back in. Using defaults read -g -g com.apple.mouse.scaling returns 2 initially, and after I set the speed to fast, it shows 3 on subsequent reads. I have also reset NVRAM but to no avail. However, resetting NVRAM had the, undesired, effect of wiping my UEFI boot settings and now I can't boot into my Ubuntu partition. (Not very happy at the moment!)

The interesting thing is that while my Mac is on the login screen, the mouse tracks exactly how I want it (perhaps too fast since I've been playing with the settings).

Is there any other command I can issue in the terminal to get my mouse working the way I like it and how it was before this latest update?

  • The problem has gone away! It appears that this may have something to do with XCode, which I upgraded to 8.3 at the time, and a couple days ago upgraded, again, to 8.3.1. Since I've had 8.3.1 installed, everything is back to normal. – gone Apr 12 '17 at 4:48
  • I'm using Xcode 8.3.2 and experiencing the problem right now. I'm not sure what I should do to remedy the situation. – TylerJames Apr 25 '17 at 14:37
  • @gone Do you use the option "Reopen when logging back in" at shutdown?apple.stackexchange.com/questions/281155/… – Broken Link Apr 26 '17 at 3:07
  • @Broken: no, I don't. – gone Apr 26 '17 at 3:23
  • @Tyler: I have upgraded to 8.3.2 and my mouse is still working fine. – gone Apr 26 '17 at 3:24
2

I ran into this problem this morning. After trying several things which themselves did not work I finally found the solution:

Uninstall SmoothMouse

The app is no longer supported by the developers and they recommend removing it.

To Uninstall SmoothMouse

  1. System menu (the Apple logo) -> System Preferences
  2. Find SmoothMouse in the bottom section and open it
  3. Open the About tab in the SmoothMouse settings and click Uninstall.

You might need to restart afterwards but that fixed it for me.

1

I've got a much simpler solution that worked for me; hopefully it will work for you as well. If you go into your system preferences at the bottom there should be a new application called "smooth mouse." Simply open that up, uninstall it, and you should be good to go!

  • With the Xcode 8.3.1 update, my system is working fine again, with "smoothmouse" still installed. Do you have Xcode installed? – gone Apr 14 '17 at 9:16
  • I marked TylerJames' instructions as the answer because his presentation of the solution is more helpful. – gone Jun 17 '17 at 3:47
0

You can eliminate this glitch as I have and many others by rolling back to your most recent version of Sierra preceding 10.12.4. In order to do this by the method I am recommending, you must have been using time machine with a hard drive regularly backing up your computer or you have been using some other hard drive that has recently backed up your computer. I have a 2 TB Lacie hard drive and time machine backs up my Mac every day.

Reboot and immediately hold Command/R until a dialog box with four choices appears. Click the top choice, MacOS Utilities. You soon will see a list showing dates, times and operating systems. Pick the very last one that occurs just before the the first presence of 10.12.4. I did it today, April 8th, 2017 at 4:30 AM and picked something around 4:00 AM on April 7th, one day earlier.

After you click continue, you will be asked if you really want to erase your hard drive. Click in the affirmative. What will happen is your entire hard drive will be erased and replaced with everything that was on your hard drive just before you upgraded to 10.12.4. If you have an important file that you have just written, I suggest printing it out. I printed out a page in notes. Upon the restoration, at first it was missing, but then was unexpectedly restored after all. The erasing and replacing took one hour.

When done, a screen appears that includes an earth icon at the top with a field right below where you enter your administrator password. Then click the right arrow beside the field. Then some brief Mac setup tasks occur followed by the importing of all your email. You will immediately notice your mouse tracking normally.

  • Well, no time machine backup here :(. – gone Apr 8 '17 at 15:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .