1

I tried to configure the Mail App for my Mail Server using STARTTLS on Port 587 but it does not seem to work. The app complains that there is no connection possible whether I check to use encryption or not. In the server logs I see that the iPad connects but does not issue a STARTTLS command. I found these questions 1, 2 that suggest that iOS does not support STARTTLS but this sounds quite unreasonable. So I would like to confirm that iOS does not support STARTTLS or that the error has to be found somewhere else. Other devices can connect without problems.

0

The problem was not STARTTLS, I was able to verify that the mail app supports STARTTLS. My problem is that the iOS 9 mail app does only support old and insecure SSL/TLS protocol versions. Usage of these versions (TLSv1.0, TLSv1.1, SSLv2 and SSLv3) is forbidden by my mail server for security reasons. Since the iOS 9 mail app only supports these insecure protocol versions no connection is possible.

See also 1 and 2.

| improve this answer | |
  • Is that also the case with iOS 10? It's rather surprising. – user11633 Apr 5 '17 at 18:41
  • 1
    @Phong It does not seem so, but I am not able to verify it since my device does not support iOS10 – Gea Apr 5 '17 at 19:44
  • People seem to be saying it was fixed in the iOS 10 betas, then pulled for 10.0 releaseā€¦ before being fixed for good in 10.1 šŸ˜³ – user11633 Apr 5 '17 at 23:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .