I installed the Google Play Music app on my Macbook (Sierra 10.12.4) then uninstalled it. Now my Touch Bar music controls no longer work with iTunes. How can I reset it?

  • 1
    Basic question but have you rebooted to see if that helps?
    – fsb
    Apr 4 '17 at 18:21
  • 1
    Yes I did, and that didn't fix it. Apr 6 '17 at 14:42
  • The controls in the iTunes portion of the Bar work fine when iTunes is running. It is only the generic music controls (rewind,play/pause,ff) that don't work. May 11 '17 at 16:15
  • 2
    I'm just wondering if you're still having this problem? Usually resetting the NVRAM and SMC solves most random issues with the Touch Bar, but if this hasn't helped there are other suggestions I can add to my answer. Also, did you try reinstalling iTunes as suggested by fuccboi?
    – Monomeeth
    May 15 '17 at 11:43
  • I am having this same issue. When iTunes is open right in front of me, the play pause button will work, but if music is playing while I'm on safari or typing in Word (and iTunes is open on one of the other desktops), the abbreviated controls with play/pause do absolutely nothing. It's pretty frustrating, I just bought a new MacBook Pro over the weekend so everything is up to date. Haven't yet found a solution to this problem!
    – Brooke
    Feb 1 '18 at 1:25

The first thing I would do is reset your NVRAM.

Resetting the NVRAM on Late-2016 MacBook Pro models

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). To reset the NVRAM on all Late-2016 MacBook Pro models (with and without Touch Bar) follow these steps:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then immediately press the commandoptionpr keys.
  3. Keep these keys pressed down for at least 20 seconds!
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

If resetting the NVRAM doesn't resolve it, try resetting your SMC as well.

Resetting the SMC

  1. Shut down your Mac
  2. Unplug the power cable from your Mac
  3. For 10 seconds, press and hold at the same time the shiftcontroloption keys (on the left side of the built-in keyboard) and the power button
  4. After 10 seconds let go of all keys and the power button
  5. Plug in the power cable
  6. Turn your Mac back on with the power button.

Let me know how you go, as there are other things you can try. However, I've found that resetting the NVRAM and also the SMC will usually resolve unusual or random issues pertaining to the Touch Bar.


This edit adds further things to try in order to resolve this issue. However, since macOS 10.12.5 has just been released, I would update the OS prior to trying the following solutions.

Use Terminal to kill the Control Strip

This is a straightforward way to manually reset the Control Strip. To do this:

  1. Launch the Terminal app (by default located within the Utilities folder)
  2. Enter the following command killall ControlStrip (or you can just copy and paste it in)
  3. Press return

There is no need to restart the Mac after doing this.

Change what the Touch Bar shows

In System Preferences you can change what the Touch Bar shows. I would change this, exit System Preferences, and then change it again (if necessary).

To do this:

  1. Got to Apple > System Preferences
  2. Click on the Keyboard preference pane
  3. Ensure the Keyboard tab is selected
  4. Around the centre of the screen you'll see a Touch Bar shows drop-down list
  5. Change the selection to Expanded Control Strip (if this is already selected, change it to App Controls with Control Strip)
  6. Exit System Preferences
  7. Test your Touch Bar music controls
  8. If it doesn't work, repeat steps 1 to 5 and change the Touch Bar shows drop-down list selection back to the original selection and test again

Troubleshooting steps

If all else fails, you can try these troubleshooting steps:

  • Function keys - Press the fn key and try using the F7, F8, and F9 keys respectively as your media control keys and see what happens.
  • Use another user account - Try using another user account temporarily to determine if the problem persists. If you don't have another user account, you can add one in System Preferences > Users & Groups. Once you've added it, log into it and see how your media controls work.
  • Safe Mode - Boot your MBP up in Safe Mode and try using the media controls keys. To do this, hold the shift key down as you boot up. This will take a little longer to boot as your Mac cleans caches, runs some diagnostics, etc. Once you've tested, exit Safe Mode by restarting your MBP and then test your media control keys again.

Once you've tried these troubleshooting steps, report back on what you found.

  • Tried both, detected no changes to my system whatsoever, and the problem remains. May 15 '17 at 15:32
  • Since macOS Sierra 10.12.5 is now available, I recommend you update the OS and reporting back on whether that has any impact on this issue. If not I'll add some other suggestions. Good luck!
    – Monomeeth
    May 17 '17 at 6:50
  • I've updated my answer with some additional suggestions for you to try. However, if you haven't already done so, I recommend updating to macOS Sierra 10.12.5 first.
    – Monomeeth
    May 18 '17 at 11:28
  • Installed the macOS Sierra 10.12.5 patch, and the problem remains. May 19 '17 at 15:48
  • Just a couple of things: (1) Earlier you commented The controls in the iTunes portion of the Bar work fine when iTunes is running. It is only the generic music controls (rewind,play/pause,ff) that don't work, can you clarify this for me? Are you saying the generic controls work when iTunes is running but not otherwise, or that the generic controls don't work at all? I'm now second-guessing whether I originally interpreted this correctly. (2) Have you had a chance to try everything in my answer so far?
    – Monomeeth
    May 19 '17 at 23:06

What does work is quitting iTunes and playing a video on YouTube via Safari. This kicks/resets the media controls, and re-opening iTunes now correctly binds to the media volume.

The problem is iTunes (exists on, running macOS 10.13.1). I've yet to find the root cause of this problem (either when a phone call comes in via Handoff or some other problem) underlying cause.


Google Chrome is the issue for me. iTunes now works fine with the media controls (Mo Firouz's answer above got it working again with the Safari idea), and so does Safari and even Spotify. But the moment I open Chrome, the media button becomes unresponsive again.

Try quitting Chrome, and either use Safari to make it work again, or just restart (ensuring Chrome won't automatically open).

  • 1
    Just closed chrome, then opened iTunes and re-opened chrome. Everything's now working right. Thanks for pointing to Chrome.
    – adonike
    Jul 26 '18 at 1:56

Because you say that the rest of the bar works even in iTunes, I really think this is probably an iTunes issue. I would try & reinstall.

Try to throw iTunes in the trash - if it doesn't let you (it probably won't) you'll have to change the permissions. Right click & select Get Info. Set everyone to 'read & write' under permissions & it away again, then go to the App Store and go to Software Update to install it again.

  • Changed perms, uninstalled, but Software Update detected no changes to my system. Had to manually download the latest MacOS Sierra, reinstalling. May 15 '17 at 15:34
  • Reinstalling the MacOS Sierra update after uninstalling iTunes also did not resolve the problem. May 15 '17 at 16:36
  • There is definitely an app conflict going on, I have no idea how Google Play's music app could have caused this. Can I have you test this issue on a new user account? You can make one in Users & Groups over in System Preferences. Make sure it's an administrator - no iCloud necessary. Test it out there - if it functions ok, test it out using your exact library. You can share it with your test account using these instructions here May 16 '17 at 2:58
  • Hey my guy, ever get a chance to test this out? May 24 '17 at 4:06

Uninstalling iTunes and reinstalling did not fix the problem.

Resetting the NVRAM and/or SMC and changing the Touch Bar settings did not fix the problem.

The installation of iTunes 12.7 fixed the problem.


This function is broken.

Download HIGH SIERRA MEDIA KEY ENABLER from http://milgra.com/high-sierra-media-key-enabler.html to fix it

  • If you have an affiliation with the software you are promoting, you must disclose this in the answer.
    – grg
    May 10 '18 at 13:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .