2

Is there a way to have it so I only get messages and texts sent to my cell phone on my cell phone and only iMessages sent to my email on my Mac?

For instance now if someone sends me a message to my email address, I get it on my Mac AND iPhone. For that particular message I would only want it on my Mac.

Conversely, if someone sends me a text message to my cell phone, I only want that to show on my iPhone. I got this part right by going into Messages preferences and deselecting my cell phone number.

However, if I try to remove the email address from Messages on my iPhone I get the message that "You will no longer be able to receive iMessages at _____ on any device". By device do they mean iPhone, iPad etc or does that include Macs?

1

What's happening is iCloud is syncing your message settings across devices. You'll need separate accounts to accomplish this.

You will need to first remove this email from your AppleID (presuming it's an alternative email on your AppleID).

Create an iCloud account for your Mac using just your email and log into that on iMessage on your Mac. This way you have a totally disconnected account and changing the settings won't effect all of your iCloud-connected devices on your first account.

  • Oddly enough it just stopped happening. Now only texts are going to my iPhone and messages to my email on my Mac. Very strange, didn't change a thing. Thanks. – Tom Apr 4 '17 at 14:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .