0

I am using a Macbook Pro system with El Capitan that has an external monitor plugged into the lightning port and has my desktop expanded across the laptop screen and the external monitor.

Whenever I start an RDP (v8.0.38) session (by this I mean connect to another computer, and not just start the RDP application), the session window always starts in full screen mode and covers the entire desktop. This is sort of OK when I am only using the laptop itself. But when I have the external monitor plugged in, the RDP session window extends across both the laptop screen and external monitor as one big RDP window. The only way I can get the RDP session window to only cover one physical screen is to disconnect the external monitor prior to starting the RDP session, and then plug the monitor back in.

If I don't remove the external monitor, and then instead just try to change the RDP session window resolution (via ⌘-1) then weird things happen to the RDP session window (I see a blank window) and I end up closing the RDP session and starting all over again.

So how do I start an RDP session in windowed and not full screen mode?

  • I'd just try the beta rather than fight the existing release. many improvements - blogs.technet.microsoft.com/enterprisemobility/2016/03/30/… – Tetsujin Apr 4 '17 at 12:24
  • @Tetsujin Interesting, I look forward too the update. But I am not feeling the love right now for a pre-release app of unknown issues when I have work to do and at least know what I am dealing with. – Peter M Apr 4 '17 at 12:30
  • It's been stable for a year. – Tetsujin Apr 4 '17 at 12:54
  • @Tetsujin I was going just fine then until I had to have 2 simultaneous RDP sessions. No matter what I did with my current RDP program I couldn't get it to work nicely. So I went and downloaded that Beta version (which was actually last updated 2/13/17) an things started working nicely. – Peter M Apr 4 '17 at 13:13
  • I thought that this is some kind of setting for the RDP. Unfortunately I'm not behind my Macbook now so I can't check it for you – Jules Apr 4 '17 at 13:15

You must log in to answer this question.

Browse other questions tagged .