1

It looks like keys with tilde ` and section § glyph are not working with OS X. I found a question on Official Apple Support Communities but there is no usable answers.

I highlighted a keys that does nothing.

tilde and section keys not working on Apple Wireless Keyboard A 1314 on OS X Sierra and El Capitan

I checked that on OS X Sierra on my MacBook 12" and on hackintosh with El Capitan 10.11.6. I do not have older version of Apple desktop OS to check that keys is physically working and not broken inside or on keyboard logic board.

I think that keys must be physically okay because this keyboard was into cardboard packaging as I bought it for a few years and now I found it and want to use with latest OS X.

Only workaround I found is open keyboard window and click that keys if I want to print them. But I'm a programmer and it's not really handy.

  • What keyboard layout are you using according to your system preferences? – Jules Apr 4 '17 at 8:12
  • @Jules I tried to switch between ABC, USA, ABC Extended, just nothing happened when I click that keys. – Даниил Пронин Apr 4 '17 at 8:14
  • Have you tried the British or British -PC or US International - PC keyboards? – Mark Apr 4 '17 at 17:03
  • @Mark I just tried British, British PC and Hebrew. This buttons not working not because of keyboard layout I think. – Даниил Пронин Apr 5 '17 at 0:14
  • Do you really still think those keys are physically ok? If not, perhaps good to remove that from the question. – Tom Gewecke Apr 5 '17 at 15:07
1

I'm not 100% clear on what you're asking, but what I can tell you is:

  • I use a number of Apple Wireless A1314 keyboards with various iMacs and MacBook Pros and the tilde ~ key works fine on all of them.
  • I haven't actually used any of this model keyboard on a Mac running macOS Sierra, but I have on Macs running Mac OS X Snow Leopard all the way up to Mac OS X El Capitan and the ~ key works fine on all of them.
  • If you actually meant the ` key (which on my keyboard is the same physical key as the tilde ~ key), then this also works on all of them.
  • As for the Section Sign (§), I've always achieved that with a option6 keyboard shortcut (i.e. there is no physical key labelled as § on any of my Apple Wireless A1314 keyboards.

If the above isn't helpful, you could try starting your Mac in Safe Mode just to see if that makes any difference in your scenario.

Boot into Safe Mode

Follow these steps boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of whether your keyboard now works as you want?
  6. Exit Safe Mode by restart your Mac as normal
  7. Test your keyboard again

Once you've tested in Safe Mode and afterwards, let us know how you went.

  • Section sign at top left and backtick next to the left shift is the standard printing on English International and British Apple keyboards. You are talking about ANSI and he is using ISO. – Tom Gewecke Apr 4 '17 at 16:20
1

This was really supposed to be a comment, as I'm just throwing around guesses, but it got too long.

I've had a similar issue before where these exact keys input the wrong characters. You're saying they just don't seem to work, so I'm not sure if this is the same problem or not.

The problem I'm talking about is one that may present itself when you ignore the Keyboard Setup Assistant first time you plugin the keyboard or if you accidentally press a wrong key in the Keyboard Setup Assistant.

...the solution to the above problem is to redefine the keyboard type:


If that doesn't help, maybe you should try Karabiner. It has this EventViewer, that you could use to figure out what keys it thinks you are pressing and what they are outputting. If the keys really are not broken, you should be able to reassing them to output what you want using Karabiner.

Karabiner has tons of presets for changing keys, but you can also use private.xml file to add your own key changes.

  • I just removed com.apple.keyboardtype.plist and rebooted. Window is appear, but when I press backtick key… nothing happened. – Даниил Пронин Apr 4 '17 at 12:09
  • I just launched Karabiner, open EventViewer window, press backtick key and section key… and nothing happened. Other keys was in log. – Даниил Пронин Apr 4 '17 at 12:10
  • You should get this window after pressing that button. I can only guess, but maybe your mac doesn't somehow recognize this keyboard properly and therefore it doesn't give you that window.. Or it could have something to do with it being hackintosh? I don't really know anything about hackintosh or problems they might have, I'm just spitballing here. Do you have any other keyboards to try? The key presses not showing up in EventViewer to me says that those keys are broken... If possible, you should test the keyboard in a Windows computer... maybe. – Joonas Apr 4 '17 at 12:28
  • 1
    One thought I had was that Karabiner has this method: __SetKeyboardType__, which doesn't have documentation, only a few samples. I don't really know exactly what it does, but you could try the samples. My experience is that the dev of Karabiner gives awesome support in the Github Issues page. Maybe you could ask there. The thing is, even if those specific keys are broken, you should still be able to launch the Keyboard Setup Assistant, so there is a chance there is something weird going on and that they're not broken. – Joonas Apr 4 '17 at 12:32
  • Sorry, I actually read your first comment all wrong and therefore my two comments above are probably mostly useless. Since trying to change the keyboard type didn't seem to have any effect... This may be the stupidest idea, but what if you do it again, but press Z instead of the actual key that is next to your Shift key? (Z is the key on the right side of left shift in US keyboards). – Joonas Apr 4 '17 at 12:43
1

If your main problem is making a tilde, a workaround for this is to switch to the US International PC layout and use Option - n plus space.

Or you can switch to the British PC layout, where you make tilde via Shift \ .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .