0

After updating to iOS 10.3 (and 10.3.1) there is a random, additional folder in Mail app attached to my Gmail account, named [Google Mail]. Prior to this update it was not there.

It's similar to a well-known older issue where all folders nested themselves under a top-level label of the same name. The answer there was to put [Google Mail] into the "IMAP Path Prefix" field in the Mail account settings. That, as mentioned below, is not helping for this problem.

Here's what I know:

  • If I put something in this folder on my phone, a label appears on the Gmail side. If I leave it empty, no label appears on the Gmail side.
  • If I add a label named [Google Mail] and turn IMAP on (on the Gmail side), the folder font becomes dark and the folder becomes active in the iOS Mail app. You can tap into it and see what's inside.
  • Putting [Google Mail] or any variant of that into the "IMAP Path Prefix" field in Mail settings causes an error in Mail saying that the IMAP settings must be wrong.
  • Trying to delete the [Google Mail] folder from the iPhone side causes an error bubble that says the folder cannot be deleted.
  • Deleting the label on the Gmail side only causes the folder font to "gray out" on the iOS side.
  • If I turn on IMAP for folders like Starred or Important, they nest themselves under this [Google Mail] label.

I've searched all over and can't see anyone talking about this. Any suggestions are greatly appreciated.

My Gmail mailbox on my iPhone 7:

My Gmail mailbox on my iPhone 7

My Gmail account settings on my iPhone 7: My Gmail mailbox on my iPhone 7

1

I had the exact same issue and found this solution online. It's working for me and the [Gmail] folder is no longer there. I think you would just substitute [Google Mail] for [Gmail]. Good luck!

"That folder is where gmail store all your mail (like the enclosing folder), I think it's a weird artifact of the way that Google have designed their IMAP system.

In Apple Mail, open the Accounts preferences, select the Gmail account > Advanced Tab. In the 'IMAP Path Prefix' insert [Gmail] (or however the folder is named - for me it is [Google Mail])."

  • I actually explain in my question that this is not the solution, but many thanks for the reply. – user231673 Jul 24 '17 at 19:44

You must log in to answer this question.