2

I recently installed Windows 10 on my MacBook Pro (Late 2011). I installed the drivers I could find from the internet (I installed this package https://support.apple.com/kb/dl1721?locale=en_GB) and everything is working fine (kind of very bad performance) but the sound. I can't get it to work, the speaker in the menubar (in windows) shows a red cross and when I hover the mouse over it it says: No Audio output device installed. In Device Manager, the internal speaker appears but it displays an initialization error (code 10). I wiped macOS during installation so I have no access to it (or to recovery mode). Please Help.

  • Are you using Bootcamp? Did you attempt to make a driver disc from the bootcamp installer and use that to install the appropriate Windows drivers for your hardware? – jimmy0x52 Apr 3 '17 at 21:37
  • Nope, I wiped my entire hard drive. Originally I was going to install macOS again and then use bootcamp to install Windows but since I don't use macOS anyways, I chose to install Windows only. – Jacob Soffer Apr 3 '17 at 22:31
2

For anyone stumbling upon this thread, some answers here are misleading. You can install Win10 on a Late 2011 Macbook Pro.

But when you install it in EFI mode, you will have problems with sound - this can't be solved with drivers, as older (pre-2013) Macbook UEFI will simply not expose the sound card interface to Windows. You will also encounter problems with discrete graphics driver (eg. you can't use hardware acceleration or adjust screen brightness).

The easiest way to get it to work is to reinstall Win 10 in Legacy/BIOS/Hybrid MBR mode that Bootcamp offers. This is the best guide on how to do this: https://www.reddit.com/r/mac/comments/3rzxd5/guide_windows_10_bootcamp_on_unsupported_macs/

Quick workarounds:

  • use Bluetooth speakers/headset

  • Use a USB audio dongle

They will work independently of the sound card.

  • I've had the same problem with the same setup. The bluetooth headphone workaround worked a treat. – Colin May 2 '18 at 7:59
1

Read the webpage you downloaded the support software from more carefully.

Note: If you are using one of the Macs listed below, you should download Boot Camp Support Software 5.1.5621 instead:

  • MacBook Pro (13-inch,15-inch & 17-inch Late 2011)

Try downloading and installing Boot Camp Support Software 5.1.5621 and that should fix your problem.

  • Tried it, sound still not working – Jacob Soffer Apr 4 '17 at 23:33
1

I would check out this link here. Use Windows 10 on your Mac with Boot Camp

System Requirements

You need support software (drivers) installed with Boot Camp to use Windows 10.
This software is automatically downloaded when you use Boot Camp Assistant.
Boot Camp supports 64-bit versions of Windows 10 when used with a supported Mac.

Here's the Compatibility Charts for Windows 7.

The MacBook Pro Late 2011 is not listed on the Windows 10 compatibility charts.

**But really, here's the guide for installing and setting up Windows on a Mac support.apple.com/en-us/HT204923 support.apple com/en-us/HT204923 **

I did also poke around and found this guide for installing it sans bootcamp fgimian.github io/blog/2016/03/12/installing-windows-10-on-a-mac-without-bootcamp . But, actually, it's really a guide to doing everything manually past downloading Bootcamp from Apple.

I feel like you need to do this on your own, or an near identical machine. I'm guessing it downloads the specific driver package for your exact machine \ model.

Had to ruin some of the links here since I don't have enough reputation.

Sorry. :(

1

If anyone is still interested I have found the solution for audio on MBP 2011 Windows 10 UEFI installs - it has taken me 4 years to figure out. I was given the answer from a tutorial only adjacently related -here:

https://egpu.io/forums/pc-setup/fix-dsdt-override-to-correct-error-12/

essentially what we knew was that windows didn't 'see' the correct audio devices when booted in pure efi-

The part that was frustrating to me was that many users like myself have lots of UEFI installs on their 2011 MBP and those OS's have no problem 'seeing' the HD audio controller -

So what was windows doing different?

I had messed around with mm commands in a UEFI shell (The shell provided in the rEFIt package) to no avail*

I had tried to pass SETPCI commands from grub into Windows 10- no luck*

A quote from the link above got my brain spinning

"A Windows system's DSDT table root bridge definition (ACPI PNP0A08 or PNP0A03) is usually confined to a reserved 32-bit space (under 4GB) budgeted to be large enough to host the notebook's PCIe devices. A watermark TOLUD value is then set and locked in the system firmware. Windows OS honors the root bridge definition and will allocate PCIe devices within it. macOS ignores the root bridge constraints as too does Linux when booted with the 'pci=noCRS' parameter. Neither of those OS require a DSDT override and can allocate freely in the huge 64-bit PCIe address space"

So Windows 'honors' the root bridge and OSX and linux disregard it --hmmm interesting.

As someone who also deals in hackintoshes I am very aware of DSDT's and how editing them can help get OSX running on home brew PC hardware- I had played around with installing Clover (the UEFI bootloader almost synonymous with Hackintoshes) on USB thumb drives and putting the DSDT from my MBP 2011 in the /Clover/ACPI/Windows folder - still nothing-- I thought that pointing windows to a DSDT would be enough.......

A side note is that there are people who have 'bricked' their real Macs when using clover, I have never had that issue personally (a sub-link in the link above describes such a situation)*

If you follow the guide and make a modified DSDT (one that add 'qwords' to the dwords section) you can test it in two ways-

newly added qword section

I used Maciasl to extract and edit my DSDT to add a 'Qword' section - I placed the DSDT in two locations /EFI/Clover/ACPI/Patched [not sure if that one matters] & /EFI/Clover/ACPI/Windows

holding ALT/option during bootup I selected "EFI Boot" from the USB clover and booted into Clover

for the exact Clover configuration send me a message

After booting into windows the sound card was immediately working (this was because I had installed the cirrus logic drivers from bootcamp 4) - the display audio driver in device manager had an exclamation point but I was able to install the display audio driver from intel's driver support for the i7 2470m CPU in this machine-

audio devices in device manager

I also looked at device manager via 'by resources' and saw that a new entry 'Large memory with an address range appeared

memory map

And low and behold the address range for the 'large memory section' contained the range for the hd audio controller

enter image description here

I then wanted to see if the method described in the initial link posted above where you force that memory map into the registry and turn on 'test signing' worked --

it did, which allowed me to boot directly into windows without the help of clover --

*NOTE: when I tested the registry method I skipped the first few steps since I already had a modified DSDT- I did need to create the 'C:\dsdt folder and extract the windows binaries to that folder - but I did not use their acpi dump nor compiler (I check for errors and compiled my dsdt in Maciasl in OSX)

I would gladly go more in depth but I doubt there are many more who need this information- just glad to have figured it out without the BIOS emulation of bootcamp- going to test this method on other 'pre 2013' Macs with non complient UEFI bios'

0

enter image description here

I fixed the problem on my MacBook Pro (Late 2011).

1.Download BootCamp6.

2.Run as administrator on the win10 command line :

your bootcamp6 file directory\BootCamp6.0.6133\BootCamp\Drivers\Apple\BootCamp.msi
  • Answers on Ask Different need to be more than just a link. We expect answers to be self contained, since if your link goes down, or the link points to a non-english site, your answer will be useless. Paraphrasing the source and including any relevant information in the answer will ensure it stays relevant – nohillside Dec 2 '18 at 9:44
  • So at the very minimum please include the actual command line to run as text so people can copy/paste it. If you also can take some of the explanations from the linked page and paraphrase them in english: even the better. – nohillside Dec 2 '18 at 9:47
  • Either point your download link to an official Apple URL or delete your answer! – user3439894 Dec 2 '18 at 11:37
  • You do not need to run the Boot Camp Drivers .msi file from the Command Line, simply right-click on it and select Run as administrator. – user3439894 Dec 2 '18 at 12:14
-1

You just have to delete the audio file of realtek from bootcamp and make the install this solution works for me.

You must log in to answer this question.

protected by Community May 9 at 9:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .