6

I have two external monitors on my MacBook Pro 2015 15" and I was doing an adjustment on the display arrangement yesterday when suddenly the displays on the arrangement tab gone.

enter image description here

I tried already:

  1. Restart the computer
  2. Unplug and plug all the cables
  3. Change cables
  4. Reset NVRAM
  5. Reset SMC
  6. Click on detect displays
  7. Create another admin user

The strange thing is when I click on Mirror Displays, the displays appear but right after I unmark that they're gone again.

enter image description here

  • Which version of macOS are you running, on which hardware? – nohillside Apr 3 '17 at 9:21
  • Last one, 10.12.4 - MacBook Pro 2015 15". imgur.com/a/g3giE imgur.com/ynEhEIi – robot11 Apr 3 '17 at 9:25
  • Is anything showing up on the displays? Also, did you try unsetting the "adjustment," whatever that was? – Allan Apr 3 '17 at 10:56
  • @Allan yes, the displays works perfectly, but I can't move windows between them. The adjustment I was doing was simple moving the displays to a better arrangement. – robot11 Apr 3 '17 at 19:26
  • I have the same problem, when i press gather windows, the settings window pops up for the screen im using. – Granny Sep 29 '17 at 13:29

You must log in to answer this question.

protected by Community Oct 10 '17 at 19:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .