1

Every few days, my system gets into a state where a CD won't mount or eject. When I run Disk Utility, it hangs at "Loading disks". Disk Utility hangs

I used diskutil to see that the CD is /dev/disk4. The CD currently in the drive has twelve tracks, so the number of mount points looks correct.

/dev/disk4 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:        CD_partition_scheme                        *391.4 MB   disk4
   1:                      CD_DA                         32.0 MB    disk4s1
   2:                      CD_DA                         39.4 MB    disk4s2
   3:                      CD_DA                         29.7 MB    disk4s3
   4:                      CD_DA                         24.9 MB    disk4s4
   5:                      CD_DA                         40.0 MB    disk4s5
   6:                      CD_DA                         39.4 MB    disk4s6
   7:                      CD_DA                         36.8 MB    disk4s7
   8:                      CD_DA                         25.7 MB    disk4s8
   9:                      CD_DA                         31.2 MB    disk4s9
  10:                      CD_DA                         32.6 MB    disk4s10
  11:                      CD_DA                         35.1 MB    disk4s11
  12:                      CD_DA                         24.5 MB    disk4s12

When I try diskutil eject /dev/disk4 or diskutil eject /dev/disk4s1 I get Volume timed out while waiting to eject.

If I reboot, the CD in the drive is mounted fine.

I'm using a Newer Technology miniStack connected to a late 2015 iMac running OS X 10.11.6.

Is there a way to force the CD to eject to save myself from having to reboot my computer every couple days?

  • Have you tried drutil eject or drutil eject internal ? I've just found your issue, on track with mine - apple.stackexchange.com/questions/301567/… – seven Oct 9 '17 at 20:36
  • The problem went away when I updated to 10.12. – SSteve Oct 9 '17 at 23:50
  • lucky you @SSteve mine is going on strong... – seven Oct 10 '17 at 10:18

You must log in to answer this question.

Browse other questions tagged .