I'm running El Captain 10.11.6 (15G1421) with all updates. I've recently updated to Safari 10.1 (11603. and now I get "Blocked Plug-in" whenever I click on Gmail links that lead to a PDF or even to a web page that links to a PDF.

enter image description here

Copying the link and opening it on a new window or tab works just fine! So does control-click,but not option-click or command-click.

Is there a fix or a better workaround? Can we tell Safari to always open PDFs in Preview?

Opening a console shows

Refused to load http://URL/foo.pdf because it does not appear in the object-src directive of the Content Security Policy.

Here is my full Installed Plugins list:

  • Google Talk Plugin
  • Google Talk Plugin Video Renderer
  • Java Applet Plug-in
  • and a online banking plugin.

I do have Adobe Reader 10.1.16 installed but I don't think I've installed a browser plugin for that. The "Blocked Plug-in" message does not mention Adobe.

The problem also occurs in a different machine also running El Captain that does not have Adobe Reader.


5 Answers 5


Without clicking the back button (or Command-[ ) of the browser:

  1. Although the plugin is blocked, you can still use Command-S (or File > Save As) as well as File > Export as PDF to save the file to a folder.

Alternatively, click the back button (or Command-[ ), and then:

  1. Option-click on the original link to download the file
  2. Command-click opens the PDF in a new tab (PDF will not be blocked)
  3. Ctrl-click yields the option "Download linked file as"
  • Ah, you can save the file from the "Blocked Plug-in" page! I wish I could open Preview directly but the floating "bar" does not appear at the bottom. But like I said, control-click works but not option-click or command-click.
    – lhf
    Apr 19, 2017 at 10:48
  • 1
    Can we tell Safari to always open PDFs in Preview?
    – lhf
    May 9, 2017 at 11:57
  • 1
    This question was asked here: apple.stackexchange.com/questions/106660/… Apparently, none of the methods work in the current version of Safari (10.1) May 12, 2017 at 3:46

Not an answer but a clue. I am having the same problem. It started yesterday when I installed Adobe Reader DC and selected custom install and chose not to install the Adobe Reader browser extension. Before this PDFs were showing with options to open in Preview or download.


Just right click on the pdf link and open in new tab. Its worked for me.

  • A block plugin doesn't become unblocked when you open the link in a new tab.
    – Allan
    Oct 2, 2017 at 17:07
  • Its worked for me. One of my trade statement coming as link to pdf. If i clicks it, it shows blocked plug-in. When I right clicked and opened in new window it worked for me and still works fine for me. You pls check yourself and post back. If allowed I can share the screenshots now. Bcz it still works for me.
    – cmvktpa
    Oct 3, 2017 at 6:24
  • Depending what the underlying problem is, this does sometimes work. If the PDF is blocked by a bad content security policy on the site, then this can work around it in Safari. Jan 12, 2018 at 10:48
  • Doesn't work here.
    – not2savvy
    Nov 2, 2020 at 14:08

Here is the answer, if you can resolve the problem.

Right click on any pdf file visible in Finder and press on "Get Info" menu.

enter image description here

Select "Preview.app" as default, if it is not selected and Press on "Change All..." button in "Get Info" window.

Refresh tab in Safari in that url is pdf file.

And You will see pdf file inside Safari.

Hope your issue may be resolved.



Apparently, Safari 11.0 no longer exhibits this problem.

  • 1
    The problem persists in Safari Version 11.0.2
    – k_rus
    Jan 12, 2018 at 6:27
  • @k_rus, not for me. I'm using Safari Version 11.0.2 (11604., recently released.
    – lhf
    Jan 12, 2018 at 9:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .