2

I have a 2016 MacBook Pro with macOS 10.12 Sierra. I can hit cmd+space and type a word that I would like to look up in the dictionary. If the word is Danish (my native language) it shows me the Danish definitions—that is fine. When I look up a English word, it shows me the translation from English to Dutch, which is really annoying.

Does anybody have a solution to that?

The dictionary works fine, if I just right click a word, and look it up.


I have the following dictionaries enables under the dictionary preferences: Dictionary settings

And the following Language and Region settings under system preferences: System settings

And lastly, my keyboard input language is Danish.


Update

I don't know what happen but suddenly the spotlight dictionary works again. After reindexing spotlight several times, disable and enable definitions in spotlight preferences several times I gave up, and disabled it for good. However, yesterday I enabled spotlight definitions again to state my point to a friend and it works. Strange, but nice.

1

The answer is right there in your question!

This is the image you provided: Dictionary Preferences

Notice how it says "Drag reference sources into the order you prefer?" If you notice, the first thing on the list is "English-Dansk". Try dragging "Oxford Dictionary of English" into the spot above "English-Dansk" and see if that provides the answer you are looking for.

  • It does not change anything in spotlight, when rearranging them. And the weird thing is, that the Dutch dictionary is disabled, but spotlight still use it. It seems like the spotlight definition settings are different from the dictionary settings. – Christoffer Mar 30 '17 at 20:28
  • Maybe try reindexing spotlight after you make the change I suggested? – NoahL Mar 30 '17 at 23:25
  • I have tried that too, as well as turn the definitions functionality off and on. Still the same. – Christoffer Mar 31 '17 at 10:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .