This actually looks like an iOS bug. There are quite some related issues that I cannot put all of them in the problem subject, so I am going to describe the background now.

Update by the end of 2020: Based on the follow-ups and answers, it seems that this problem still exists in iOS 14 and also occurs on Apple Watch.

iOS 10 has a region-specific function, that allows Chinese iPhone users to turn off Internet access completely, not just cellular data access. This function is associated with the iPhone model, not with cellular network operators, actual location of users, or language settings. This means it applies to iPhone bought in a Chinese Apple Store, a Chinese authorized store, or from an authorized Chinese website. Not sure if it has to be China, though. Anyway, a US model will not support this function, which means you can only turn off cellular access if your iPhone is a US model. Here is a third-party description of this function but it is in Chinese: 具透 | 你可能不知道,iOS 10 有一个中国「特供」的联网权限功能

Screenshots for this function:

enter image description here enter image description here

The disturbing problem that I actually wanted to ask, happens this way:

I have two iPhones, an iPhone 5 (Chinese model, for China Mobile) and an iPhone 5s (US model, for T-mobile, and also works with AT&T), both running iOS 10.2.1 (latest version when I was encountered with the issue). None of them has a SIM card inside, which means I cannot use cellular data on either of them.

I backed up the iPhone 5 and recovered the backup on the iPhone 5s. The motivation is simply to migrate from one to the other.

For most of the applications and settings it worked well.

However, there are two applications, which when I open them, say "Wi-Fi is turned off for name of the application". (I cannot provide a screenshot for this because this dialogue only appeared once for impacted apps, even if I re-install the apps.) The dialogue pointed me to Settings, but the US iPhone 5s does not have Wi-Fi on/off switches in the Settings, and cellular data was set to "on". Now, these application cannot use the Internet -- they just say "No Internet connection".

What I tried:

  1. Turn off cellular access of impacted apps. Problem persisted.

  2. Turn on cellular access of impacted apps, again. Problem persisted.

  3. Delete the app from the home screen, and reinstall from the App Store. Problem persisted.

  4. Go to Settings/General/Reset, and reset the network settings. Wi-Fi passwords were removed, however, when I reconnect to Wi-Fi, those apps still cannot use Internet.

Checking if anyone has had similar issue, and if possible, how to fix this without resetting everything on the iPhone 5s.

I am not sure why some apps are impacted while some others are not. Impacted apps are:

  1. CamScanner. It uses Internet to sync scanned files.

  2. 不背单词. It is an English learning app that uses Internet to download vocabulary.

This might be relevant and might not be. It could be some settings on the iPhone 5 making such difference but I no longer have access to those settings on the iPhone 5 now.

  • I'm not from China so I never heard of this, but I have two suggestions. First though, back up your iPhone 5s because you will loose the data on it if you do this. Option 1: If the apps were disabled in iPhone 5, I would recommend you enable them, then backup the 5 again. Now, load the new backup onto the 5s and see if this fixes it. Option 2: If option 1 didn't help, restore the 5s backup you took before starting. Since the 5s is American, maybe it didn't save any Chinese settings in its backup.
    – Vladimir
    Apr 15, 2017 at 21:23
  • Option 1 no longer works since the iPhone 5 has been wiped for other purpose. I will try Option 2 when I have time. @Vladimir
    – bfrguci
    Apr 19, 2017 at 9:45

5 Answers 5



It got worse after iOS 14.2 update. \WLAN and Data for Camera and some critical apps are turned off so I had to do extensive search, or the phone would become somewhat unusable.

Cause: The cause seems to be the Watch app. There are some connections between apps on the Apple Watch and iOS, and there seem to be a bug regarding how the network setting are shared and sync'ed between Watch and iOS apps. So most likely the problematic apps had been installed both on iOS and Watch.

Solution: Reset all settings. Resetting network settings wouldn't work. You have to reset all settings (no data or media would be deleted).

Go to: General > Reset > Reset All Settings. After a reset you are done.

All settings will be deleted, so you will need to do some configurations. Wallpapers, dark mode, keyboard, region, date and time, Siri, etc. However you get to keep all your apps and data, which is okay to me.

Don't forget to turn on Siri as you lose CarPlay capability if Siri is off.



Again this problem is gone with iOS 14.1 update that was applied two days ago! Apple please look after your regression test.


Sadly, this problem is still there even in latest iOS 14!

WLAN and Cellular Data will turn off for random apps and could never be turned on. Last time I saw this was on my iPhone SE 1st generation with iOS 12.

There was no way to fix the problem. I tried everything. Only after upgrading to iOS 13 did the problem go away and never came back. I thought that was the end of it. I guess there was a structural change made to the configuration table for app network access so the problem was gone.

Now I encounter the same problem with iOS 14! Nowhere to fix the problem, but can only wait for the next system update.

  • Sad to know the problem is still there. However, this is not an answer to the question and should go to comments.
    – bfrguci
    Nov 2, 2020 at 23:24
  • @bfrguci Try Reset All Settings. Answer updated.
    – dz902
    Nov 9, 2020 at 1:24
  • Thank you but the post was like 3 years ago and now I do not use those phones anymore.
    – bfrguci
    Jan 5, 2021 at 0:09
  • Btw, since you seem to have done quite a lot of research on this, too, and that the problem still exists in iOS 14, I will update the original question to remove iOS version "10".
    – bfrguci
    Jan 5, 2021 at 0:11

I tried the reset all settings on iOS 14.2 and it did not fix my problem.

However, after resetting all settings, I went to Apple Watch app -> Cellular, and manually turned on Wifi for the apps that were messed up.

This seemed to fix my problem, so I’m not sure if “reset all settings” is necessary. That being said, I’ve been battling this problem for many years and I’m happy that I found this helpful post that pointed out the Apple Watch connection!

My understanding is that this is due to my Apple Watch being a China eSim model 4, and so there are some China settings that are being sent from watch and affecting the phone apps. Probably a bug of some sort.


This bug exists all the way from iOS 10 to 14.4, and Apple did nothing for it.

Some apps don't have Apple Watch support still have this bug. I've tried hundreds of ways to solve this. The ONLY way you can get the app working is to ERASE YOUR IPHONE and reinstall your app one by one. And what is even more worse is that this bug will come back AGAIN after some days. This is just crazy and driving me mad.


Confirm this problem on iPhone 11, iOS 13.7, Chinese model. I just cannot turn on wireless data access for some apps.

The bug is even worse than OP stated. In the settings some apps show no granted access to wireless data, but it can connect to Internet and play videos, like 优酷. And some apps can connect to the Internet if I turn on VPN(shadowrocket).

  • This is not an answer, but a "I have this problem too" comment. Please use the answer box only for solutions to the OP's question.
    – cigien
    Feb 16, 2021 at 2:41
  • This doesn’t fit as a comment at all. It’s better to leave as an answer if we can’t incorporate the additional context of the problem severity in the body of the question. Confirming the issue exists in different versions is valuable as an answer as it helps people crowd source workarounds. +1 in my book.
    – bmike
    Feb 16, 2021 at 12:02

If you have jailbroken iOS 11-14 try closed source freeware NetworkDisabler

I managed to enable Wi-Fi access for com.apple.AppStore with the following:

  1. Click Add ichitaso repo at the bottom of the page
  2. In com.saurik.Cydia Sources - ichitaso repository - Tweaks - NetworkDisabler - Modify - Install
  3. In com.apple.Preferences (i.e. "Settings") make sure ON is NetworkDisabler - Enabled
  4. In com.apple.Preferences turn ON NetworkDisabler - Use Wi-Fi - App Store

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .