In my apartment, when using the AirPods with my Mac, the audio is significantly choppy, fluttery and unreliable. There are frequently small "pops" when listening to music. The issue is not present when using the AirPods with my iPhone.

The Apple Stack Exchange question you are reading now, is actually an update to my question on the same topic that was posted and resolved here previously. I had this very same issue while on macOS Sierra 10.12.4. We found out that the culprit was a bug introduced in that particular macOS version, and the problem went away with 10.12.5.

I am now on 10.12.6 and having a quite identical problem. But I'm not confident that the OS is at fault this time.

The reason is that I recently swapped my AirPods for a new pair, via an unrelated Apple support ticket. The new ones arrived via mail and I was instructed to pair them with my original case.

The new pair of AirPods seem significantly more prone to skipping, stuttering and losing connection. I did not have this problem with my original AirPods, which I also used with 10.12.6 without problems (at least that I am cognizant of).

Possible explanation

I think I have found what's causing the skipping (albeit not the root cause), and it seems to be my iPhone Bluetooth signalling with its environment. Whenever that happens, there is a glitch/pop on the Mac ←→ AirPod connection. When I disable Bluetooth on the iPhone, the problems go away.

I haven't changed anything in my environment except swapping the AirPods. No microwave in the background etc.

I am quite confident that the reason is Bluetooth interaction from the iPhone. I am just not sure how to proceed, because the weird thing is that the problems started just when I replaced the AirPods for a new pair.

Some plausible root causes are:

  • The new AirPods are in fact defect or come from a batch that are not as 'good' with Bluetooth.
  • macOS 10.12.6 introduced a bug similar to the one in macOS 10.12.4, but I didn't realize it until much later (not that likely IMO, knowing how sensitive I am to audio quality).
  • The pairing process whereby new AirPod buds were paired with an original case didn't go exactly right, and there is a firmware or software problem somewhere.

What I have tried

  • 'Hard Reset' of the AirPods according to these instructions;
  • Resetting the iPhone Network Settings after "Forgetting this device" (the AirPods) as part of the AirPod 'Hard Reset'.
  • Resetting the Mac Bluetooth Module according to these instructions.
  • 1
    If you've upgraded to macOS Sierra 10.12.4, there appears to be Bluetooth audio issues that are only resolved by downgrading to 10.12.3 until Apple pushes a new driver update.
    – user11633
    Commented Mar 30, 2017 at 19:08
  • 1
    Anecdote: My temporary solution is to use Airfoil to transmit audio from my Mac to my iPhone, to which my AirPods are paired. Works fine except for a slight latency, but good for playing music from the computer /w AirPods without choppyness.
    – P A N
    Commented Apr 2, 2017 at 12:12
  • I have this on MacOS Mojave 10.14.1. Wasn't noticeable on 10.14.
    – malhal
    Commented Nov 25, 2018 at 19:05
  • I found this problem to have started on my MacBook Pro Retina after getting the 1st-gen AirPods firmware update 6.3.2 with macOS Mojave update 10.14.4. The dropping-out, clicking, and popping is so bad that I stopped using the AirPods with my Mac. Bummer. :-( But the sound is superb on the iPhone. Commented Mar 27, 2019 at 6:59
  • Does anyone know if this is still a problem with AirPods Pro 2, which uses the H2 chip?
    – P A N
    Commented Jun 18, 2023 at 18:10

5 Answers 5


I solved this choppy audio issue with just one simple trick. (This might not work for everyone, but I solved it this way)

Short answer

If your hardware uses Bluetooth 4.0 instead of 4.2 or above, this solution is highly likely to work for you.

Open System Preferences > Sound > Input

Change sound input from Airpods to Internal Microphone

Long answer (+ Possible explanation)

(This is just my hypothesis based on my observation)

First of all, to clarify my symptoms, I am using a MacBook Pro 15 inch (Late 2013) which has Bluetooth 4.0 hardware. The choppy audio issue only happened in my MacBook Pro, and it did not happen in my other Apple devices such as my iPhone 7 Plus (which btw, has Bluetooth 4.2), nor my iPad Pro (also Bluetooth 4.2).

Based on these observations, my hypothesis is that Bluetooth 4.0 devices have too low bandwidth to handle both input/output (microphone & speaker) at a high quality. However, if I just change the audio input to the internal microphone, the Bluetooth connection only delivers sound output, so I think it can handle higher quality audio. On the other hand, if I use both microphone & speaker on a Bluetooth 4.0 device, I think the connection degrades and sacrifices audio output bandwidth in order to make room for delivering audio input.

Indeed, according to some sources, Bluetooth 4.2 is 250% faster and has 10x more capacity


  1. https://www.quora.com/What-are-the-main-differences-between-Bluetooth-4-0-4-1-and-4-2-in-the-Layers-Baseband-LMP-L2CAP-app-Layer
  2. https://www.semiconductorstore.com/blog/2015/BLE-4-2-vs-BLE-4-1/1548/
  • 5
    When Airpods mic is active the codec is SBC which sounds like crap compared to AAC when the mic is not active (Option click BT menu to see active codec). But this isn't the choppyness the OP is asking about.
    – malhal
    Commented Nov 25, 2018 at 17:28
  • Switching the input from AirPods to the Internal microphone and back worked for me.
    – Cyupa
    Commented Dec 16, 2018 at 21:52
  • This worked! When listening to music on my Mac was very choppy, stopped playing for a second every 10 seconds or so. Setting the sound input from Airpods to the Internal Mic actually worked... My mac is a top level 2019 model, should have Bluetooth 4.2 you would say. So stupid that this worked, but I'm VERY glad it did. Thanks!
    – Ronaldt
    Commented Sep 18, 2019 at 10:00
  • It indeed worked, thanks. But I doubt it that It is not about the bluetooth version. My Macbook which is late 2017 which indicates that it has bluetooth 4.2 has the same problem. It may be the sound driver problems. Cheers.
    – Jason Peng
    Commented Jan 19, 2020 at 8:16
  • I'm running a MacBook Pro (Retina, 13-inch, Late 2013) with macOS 10.15.6 and still running to this issue. I always have my cabled headphones around for calls :(
    – Ignacio
    Commented Jul 30, 2020 at 19:12

This appears to be a new audio driver bug introduced in macOS Sierra 10.12.4. As per AppleInsider:

Monday's macOS 10.12.4 update is resulting in stuttering audio for some users of USB headsets, according to multiple complaint threads on Apple's support forums and reports from social media.

The glitch doesn't appear to be linked to a single Mac model or headset brand, and many troubleshooting methods —like resetting hardware or changing USB ports —don't seem to work. People reporting the problem have noted that the issue isn't solved by a clean reinstall of macOS 10.12.4, and only seems to vanish after restoring to 10.12.3 or an earlier OS.

You may have to revert to 10.12.3, or wait for Apple to deploy a fix.

  • 3
    That's probably it. I will accept your answer if a forthcoming OS update resolves the issue.
    – P A N
    Commented Apr 2, 2017 at 10:56
  • 2
    Updating to macOS 12.5 solved this issue for me.
    – P A N
    Commented May 15, 2017 at 18:46
  • 1
    The issues are back. I swapped my AirPods for a new pair due to an unrelated Apple Support Ticket, and the new pair is extremely susceptible to Bluetooth interference from my iPhone. Turning Off Bluetooth on iPhone reduces the problems significantly, but that's not a long-term option. Nothing changed in my environment, except that I upgraded to macOS 10.12.6 recently, but that was before swapping the AirPods, and I didn't notice anything with the old pair under 10.12.6. Might be that the pair is faulty or 10.12.6 introduced a new bug?
    – P A N
    Commented Aug 1, 2017 at 16:17
  • 2
    I saw your other Question. I got the impression it was a defective pair of AirPods that you got as replacements. This happens—I’ve had a refurbished iPad Air 2 completely die on me after 3 weeks; my first replacement WATCH had a dent in it; and a refurbished iPad 2 had a sticky Home button. I don’t think this is a knock on refurbished or replacement devices in general—brand new devices also have manufacturing defects. Certainly if you updated to 10.12.6 and it was fine until the replacements came in, I’d say it’s the replacement AirPods.
    – user11633
    Commented Aug 1, 2017 at 16:22
  • 2
    @Phong I'm tempted to agree with you. I'm opening this question again just to make sure that we can rule out other problems. I feel that I need to be prepared before contacting Apple Support again, I'm sure they will not be happy with replacing my replacement AirPods... I've added a bounty to this question however so if no new solutions arise I will re-accept your answer later.
    – P A N
    Commented Aug 1, 2017 at 17:54

I was having the same issue. And for me was the apple wireless keyboard and my Logitech MX master mouse. Basically anything Bluetooth. As soon as I connected the mouse using the dongle and the keyboard with the charging cable the Apple AirPods 2 start working just fine. This is very annoying as I can not connect anything to my laptop without getting this annoying sound breaking.

  • Im having a similar issue but it is with an older apple magic mouse (the one with AA batteries). Commented Feb 27, 2020 at 18:35
  • Same keyboard and mouse, same issue. No solution? Commented Nov 4, 2021 at 17:43

If all else fails you can reset both the macOS Bluetooth Device List and Bluetooth Controller. However, this will reset all connected Bluetooth devices, including a keyboard and mouse.

In other words, this will remove all existing pairing information for Bluetooth devices, so each will need to be reconnected.

Before commencing, you will need to have the Bluetooth icon showing in the menu bar. If it is not there, open System Preferences > Bluetooth and enable the option Show Bluetooth in Menu Bar.

Resetting the macOS Bluetooth Device List and Bluetooth Controller

Follow these steps:

  1. Hold down both the Shift and Option keys and at the same time click on the Bluetooth icon in the menu bar. Once the menu is showing, release the keys.
  2. From the Bluetooth menu, choose Debug > Remove All Devices
  3. Hold down both the Shift and Option keys again and at the same time click on the Bluetooth icon in the menu bar.
  4. From the Bluetooth menu, choose Debug > Reset the Bluetooth Module
  5. Restart your Mac
  6. Setup your bluetooth devices again

Let us know whether this helps.

  • 2
    Thanks Monomeeth – I tried this but it didn't help. I've done some more research and updated the question.
    – P A N
    Commented Mar 30, 2017 at 13:28
  • 1
    Anyone had solve this ?
    – Curnelious
    Commented May 14, 2017 at 9:16
  • 1
    macOS Sierra 10.12.5 isn't too far away, so hopefully it'll be resolved with that release. If you can't wait, or you're interested in getting involved with Apple's beta program, you can read more here.
    – Monomeeth
    Commented May 14, 2017 at 9:48
  • @Winterflags You may recall I mentioned a couple of days back that macOS Sierra 10.12.5 isn't too far away. Well, it's now available, so I recommend you update to that and see whether your particular audio issues are resolved. Good luck!
    – Monomeeth
    Commented May 17, 2017 at 6:44
  • I was having this same issue with my BeatsX Earphones (the one's with the W1 chip inside) and my Mac on OS 10.12.6. Turning off my iPhone's bluetooth sometimes helped before but it wasn't a fool-proof method. This seemed to have solved it for now. Commented Sep 1, 2017 at 14:35

This is something not already mentioned, so worth a separate answer in case it helps someone. Make sure you are not far away from your other connected bluetooth devices. I had my bluetooth keyboard in another room and my Airpods Pro started crapping out presumably because the keyboard in the other room was constantly disconnecting and reconnecting. Since I wasn't using it at the time I disconnected and voila! Airpods are working again.

  • This fixed it for me. As soon as I disconnected my trackpad, the sound suddenly became clear. I'm on macOS Sonoma 14.5 in 2024 and this is still an issue. Commented Jun 1 at 6:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .