0

For the last several months, I have used wifi to connect to the internet through an unsecured wifi network that my organization controls - had been working fine since last night. Today my iMac shows that I am connected to the proper network same as always but I am unable to connect to the internet in any way (web browsers, ssh, ping, etc.). The Network settings show me as connected and assigned proper IP and DNS numbers. Renewing DHCP Lease doesn't seem to make a difference. Also because this is a large wifi network managed by an organization and not me personally I contacted the administrator to make sure I hadn't been blacklisted (I had not) and also tried spoofing a new MAC address, which also didn't work. I also know that it is not an issue with the router itself as I am typing this from another device right next to my iMac connected to the same access point (several other devices are also connected with no problem).

I'm unsure if it has any significance but I had been running a bitcoin node for several weeks on the computer and began running a tor relay a few days ago but my internet had been working since configuring the relay. I also tried stopping both services and checking that all processes were gone with ps, which didn't do anything. The output of ifconfig also looks normal to me and my computer seems to be acting normal other than this issue but I'm at a loss for how to continue debugging this problem. Has anyone encountered anything similar or have any suggestions?

Edit: It is a 2015 5K 27 in iMac running the most updated version of 10.11

  • Can you clarify the exact model of iMac and version of macOS? – Monomeeth Mar 28 '17 at 23:20
  • @Monomeeth It is a 2015 5K 27 in iMac running the most updated version of 10.11 – guribe94 Mar 29 '17 at 1:31
  • Please issue the following command route -n get default | grep gateway. Whatever IP you get, will be your gateway. Ping that address (Example: ping 192.168.1.1) If it responds back, issue the next command ping 4.4.4.4 Edit your original question with the results. – Allan Mar 29 '17 at 1:58
  • Ping does not work, request timeout - 100% packet loss. I'd update with a copy paste but I'm using a different laptop @Allan – guribe94 Mar 29 '17 at 2:04
  • Which address did you attempt to ping to? – Allan Mar 29 '17 at 2:10
1

Below are a number of things you can try (apologies for anything obvious, but I take nothing for granted).

Restart the iMac

Does restarting the iMac do anything? Rebooting can often resolve these types of issues.

Disable/Enable Wi-Fi

Similar to restarting, but without needing to. You can use the Wi-Fi menu to turn Wi-Fi off. Try this for about a minute and then turn it back on. This also often works.

Boot into Safe Mode

Follow these steps boot your Mac into Safe Mode:

  1. Fully shut down your iMac
  2. Restart your iMac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. can you now connect to the Wi-Fi network)
  6. To exit Safe Mode just restart your Mac as normal

The act of booting into Safe Mode will actually perform a number of background tasks, and this often resolves issues when you've rebooted normally.

Once you've tried the above let me know how you go.

[EDIT]

Okay, let's continue troubleshooting...

Run Wireless Diagnostics

You can use Wireless Diagnostics to analyse your Wi-Fi network. Follow these steps:

  • Close any apps you have running
  • Connect to the Wi-Fi network
  • Hold down the option key and go to the Wi-Fi status menu and select Open Wireless Diagnostics
  • Enter your administrator name and password

Now follow the steps to see whether any problems are found.

Try another 'Wi-Fi' network

It'd be interesting to see whether your iMac can get internet connectivity from another Wi-Fi network. Can you share an internet connection from an iPhone's cellular connection (or similar) and connect to that via your iMac's Wi-Fi port? Does this allow your iMac to browse the web, send/receive emails, etc?

If you can't get an internet connection, then I'd be testing your hardware, although it may be worth first resetting the NVRAM and SMC (in that order). See below for steps.

Reset NVRAM

Your iMac uses Non-Volatile Random-Access Memory (NVRAM) to store many of its settings. You can reset this with the following steps:

  1. Shut down your iMac. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your iMac reboots again and you here the startup chime.
  4. Let go of the keys and let your iMac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Now proceed to resetting the SMC.

Reset the SMC

Your iMac has a System Management Controller. It may be worth you resetting this too:

  1. Shut down your iMac
  2. Unplug it from power
  3. Wait 15 seconds
  4. Plug the power cord back in
  5. Wait for an additional 5 seconds
  6. Press the power button to turn it back on

How does your iMac go with connecting now?

Run Apple Diagnostics

If all else has failed, follow the steps below to run Apple Diagnostics:

  1. Fully shut down your iMac
  2. Restart your iMac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Regardless, take a note of what happens and let me know how you went.

  • I didn't think about safe mode thanks for the suggestion, unfortunately it doesn't work under safe mode either. Same problem, shows that it is connected and assigned an IP but I'm unable to access the internet – guribe94 Mar 29 '17 at 1:37
  • Just updated my answer with some additional troubleshooting steps. As an aside, I don't suppose that the office's Wi-Fi network can be reset? – Monomeeth Mar 29 '17 at 2:44
  • Unfortunately it can't be reset. I tried running the diagnostics and it said no problems, clearing the NVRAM and resetting SMC was also unsuccessful – guribe94 Mar 29 '17 at 18:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .