1

When I upgraded to Sierra, my shift key on the external keyboard stopped working when I press a key on my MacBook Pro Retina's keyboard. I have a setup where my left hand is using the external keyboard (to avoid pain due to chest compression), while my right hand is on the MacBook's keyboard.

Now when I press the left shift and a letter on the MacBook keyboard, the letter does not come capitalized. In El Capitan (and all other versions) this worked...

Any hints?

EDIT:

  1. it's not just shift. It's command, alt, shift, control.

  2. the modifier keys do work physically (when used with other keys on the same keyboard).

2

It might be that the shift on that keyboard does not work anymore. In that case, you should use another button as the shift button. You could try, for example, remapping the caps lock button (or some other button if you want to keep its functionality) to the left shift button using Karabiner Elements (courtesy of Tim for showing me this!). This will enable you to press the caps lock button on the external keyboard to emulate the shift button's functionality.

  • Thanks, but Shift does work physically. – KarolDepka Mar 26 '17 at 15:48
  • It might be a bit of a long shot, but could you try it anyway? Perhaps it might work. If you can confirm it doesn't, however, I'll remove this answer. – Skeleton Bow Mar 26 '17 at 15:49
  • Actually I have command mapped to caps lock on both keyboards. But pressing command on the left keyboard and, for example O, on the macbook keyboard, does NOT invoke Command+O. – KarolDepka Mar 26 '17 at 15:51
  • I just tried an external keyboard and pressing shift on it while pressing keys on my MacBook's keyboard seems to work just fine. Maybe it's just a problem with your keyboard? I'm running Sierra 10.12.3. – Skeleton Bow Mar 26 '17 at 15:55
  • 1
    Big thanks to @Skeleton Bow for the help in troubleshooting and for suggesting Karabiner Elements! – KarolDepka Mar 26 '17 at 16:53
3

[SOLUTION!] Ha!!! Now it started working. Replying to my own question (related to Skeleton Bow's answer/suggestion - thanks) : Looks like Karabiner Elements kicked it the right way somehow. Even though I did not exactly change anything relevant, just installed it and opened it. Maybe the fact of installing /using karabiner forces sierra to use the old ways of handling modifier keys? Big thanks to @Skeleton Bow for the help in troubleshooting and for suggesting Karabiner Elements!

  • Adding to it: now i've done my usual Caps-to-Command remapping in Karabiner-Elements itself, not in system preferences. Because the remapping in system preferences seemed to not work anymore now (gave up after few tries there and moved the remappings to Karabiner-Elements). – KarolDepka Mar 26 '17 at 16:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .