1

I have a question about my iMac 2015 Fusion Drive. I replaced my spindle with a SATA SSD 512gb drive. Here are the commands I used from an online instruction set to remake the Fusion Drive:

diskutil list

And saw that PCIE SSD was disk1, SATA SSD was disk0 so I ran:

diskutil coreStorage create Fusion /dev/disk1 /dev/disk0
diskutil coreStorage createVolume [lvgUUID] jhfs+ "Macintosh HD" 100%

Where [lvgUUID] was the unique Core Storage ID string

This worked great, I installed macOS and everything was grand except when I went into Disk Utility, I tried to make a partition, I am limited to making one the size of my tiny 24GB SSD and when I do make one under that size it uses the PCIE for the partition instead of the larger SATA drive. This is making it impossible to get Bootcamp up and running, since the Bootcamp Setup Assistant will not let me make a partition claiming I don't have enough free space.

Will it work to just switch the order of disk0 and disk1? Any thoughts greatly appreciated!

diskUtil cs list output:

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 7D87AFDD-C64A-4AC2-B8E4-6C098F67A384
    =========================================================
    Name:         FUSE
    Status:       Online
    Size:         534804156416 B (534.8 GB)
    Free Space:   176128 B (176.1 KB)
    |
    +-< Physical Volume 9A2B9DD4-3C79-46C2-BB4F-886B5A6B9C73
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     23037939712 B (23.0 GB)
    |
    +-< Physical Volume 3BE6757D-AE99-4C70-A0B3-CC16725BA627
    |   ----------------------------------------------------
    |   Index:    1
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     511766216704 B (511.8 GB)
    |
    +-> Logical Volume Family 8AB4FCEE-8DDF-487E-A9B9-F351BE591D2E
        ----------------------------------------------------------
        Encryption Type:         None
        |
        +-> Logical Volume 45E7132B-2676-450E-85D6-636EA3DFDC4F
            ---------------------------------------------------
            Disk:                  disk2
            Status:                Online
            Size (Total):          526809563136 B (526.8 GB)
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
            LVG Type:              Fusion, Sparse

diskUtil list output:

Charles-iMac:~ tinyhouse$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *512.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage FUSE                    511.8 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3

/dev/disk1 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         24.0 GB    disk1
   1:                        EFI EFI                     314.6 MB   disk1s1
   2:          Apple_CoreStorage FUSE                    23.0 GB    disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3

/dev/disk2 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            Macintosh HD           +526.8 GB   disk2
                                 Logical Volume on disk1s2, disk0s2
                                 45E7132B-2676-450E-85D6-636EA3DFDC4F
                                 Unencrypted Fusion Drive
  • It's unclear what you are trying to achieve: BSA doesn't require you to "pre-fabricate" a 2nd partition with Disk Utility - one existing HFSJ+ partition is expected instead. Have you tried to simply launch BSA and start formatting your "Fusion Drive"? – klanomath Mar 24 '17 at 20:08
  • Right – I was only hoping that the inability to partition in disk utility might be related. I am trying to make it so that from the two child disks, new partitions go on the larger drive. – Charles Mar 24 '17 at 20:40
  • The Recovery HD is considered to be the "last" partition of a Fusion Drive. Any additional partition (needed to install Windows) will be created as diskXsY(RecoveryHD)+1. In your case this will limit its size to ~22 GB – klanomath Mar 24 '17 at 21:13
  • Yeah I see that now, it also looks like Boot OS is on the SATA when I want it on the PCIE, any idea what I did wrong? – Charles Mar 24 '17 at 21:17
  • There is no wrong-doing. Probably the code responsible to create a Fusion Drive can't handle an SSD-SSD-combo properly and creates the RecoveryHD arbitrarily on one of the disks. How large should the Window partition be? 50 GB? – klanomath Mar 24 '17 at 21:22
0

To create a proper "Fusion Drive" in your case, you first have to create a normal CoreStorage Logical Volume Group with one physical volume and one logical volume. Then you have to install macOS. In a last step you have to add the second physical volume to the CoreStorage Logical Volume Group and expand the existing logical volume.

  • backup your main volume
  • boot to Internet Recovery Mode (or a macOS installer thumb drive)
  • get all necessary listings:

    diskutil list
    diskutil cs list
    
  • destroy the LVG:

    diskutil cs delete lvgUUID #lvgUUID: UUID of the Logical Volume Group
    
  • completely erase both disks (each to one volume with the names e.g. "data1" and "data2" but not "Macintosh HD")
  • get the device identifiers again: diskutil list
  • create a new LVG and LV on the larger disk (here I assume the 500 GB SSD has the disk identifier disk0):

    diskutil cs create Fusion disk0
    diskutil cs list
    diskutil cs createVolume lvgUUID jhfs+ "Macintosh HD" 100%
    
  • Install macOS to "Macintosh HD"
  • After configuring macOS open Terminal and enter

    diskutil list
    diskutil cs list
    
  • add the 24 GB disk (here I assume the disk identifier is disk1) to the LVG:

    diskutil cs addDisk lvgUUID disk1
    
  • Expand the main system volume:

    diskutil cs resizeVolume lvUUID size #with size e.g. 526800m
    

    If you get an error "Error: -69720: There is not enough free space in the Core Storage Logical Volume Group for this operation" choose a slightly smaller size like 526400m or 526000m

0

Another route: As klanomath pointed out to me in the comments, the system decides which is the secondary physical disk of the fusion drive in the OS by which has the recovery partition. This seems to be different than the index, or maybe is specific to running dual SSDs. So I broke the fusion drive:

diskutil cs delete lvgUUID

Then installed MacOS to just the larger SATA drive. This creates a recovery partition on the drive. After the install, back to the USB recovery and create the fusion drive this time only using the main data partition of the SATA drive while leaving the recovery partition intact.

diskutil cs create Fusion disk1 disk0s2

Then the normal

 diskutil cs createVolume [paste the UUID here] jhfs+ "Macintosh HD" 100%

Then rebooted from the recovery drive and installed from there.

Now I can partition the drive as normal, BCA works and system boots roughly .4 seconds faster using the PCIE drive (joking I can't actually tell) :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .