2

I have my Terminal preferences set to use the "Pro" profile. When I launch a Terminal session from the dock, it uses the "Pro" profile (black background). However when I launch a Terminal session from "Services -> New Terminal at Folder" in Finder, it uses the "Basic" profile (white background). How can I set it to always use the "Pro" profile?

3

After launching Terminal.app the active profile of the shell window is determined by the settings chosen in: Preferences > General > On startup open...

The profile of the next Terminal window opened or the one launched by Services -> New Terminal at Folder uses a default profile which can be configured here: Preferences > Profiles > Text: choose a profile in the left pane and hit the default button at the bottom.

  • Thanks. It took me ages to find this button on a new Apple computer. I thought I was going crazy, because I did have set my profile as the default for new windows and tabs (from an existing window), but new windows from the dock would still show me the ugly and useless default profile. Now it works like it should! – Erik Sep 21 '18 at 10:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .