2

I've been trying to connect my TV to my Macbook via HDMI cable so I can use it as a second monitor. Every time I connected it, when I check 'Activity Monitor' a task called 'kernel_task' shoots up to like 500% CPU, the fan starts spinning really fast and the whole laptop lags/freezes. The bottom of the laptop feels like it could melt glass.

I've tried a few things like:

  • Different HDMI Cable
  • Unchecking 'Automatic Graphics Switching'
  • Resetting the NVRAM

None of these things have made a difference.

Details of my laptop are as follows:

MacBook Pro (Retina, Mid 2012)

Processor: 2.6 GHz Intel Core i7

Memory: 8 GB 1600 MHz DDR

Graphics: NVIDIA GeForce GT 650M 1024 MB Intel HD Graphics 4000 1536 MB

OS: Sierra 10.12.3

I have a much less powerful Windows laptop and it can be connected to the TV without any problems. I have also tried connecting when running Linux Distros and never experienced any issues. It appears to only be on this Macbook.

Any help or advice would be greatly appreciated.

  • Have you tried these troubleshooting steps to remove some preferences and reset the PRAM? david.gyttja.com/2013/01/21/… – jimmy0x52 Mar 22 '17 at 21:36
  • one more thing worth noting: HDMI can seem laggy compared to other connectivity because of refresh rates, especially on higher res (4K) screens. If you have the option to go Mini DisplayPort to DisplayPort that can also substantially speed things up. Since this is a TV you may not, but I thought it was worth mention. – jimmy0x52 Mar 22 '17 at 21:38
2

One thing you haven't tried is resetting the System Management Controller (SMC). This is something I would definitely do, especially because of the fan speeds and high heat. However, even though you've already reset the NVRAM, I would do that first again and then reset the SMC. Below are the steps I recommend for doing both resets on your model of MBP.

Reset the NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs (such as yours) use Non-Volatile Random-Access Memory (NVRAM). I would reset this again before resetting the SMC. Here’s how to:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Ensure you have nothing connected to your MBP (TV, external Keyboard, etc) - however you can keep the power cable plugged in.
  3. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  4. Hold those keys down until your Mac reboots again and you here the startup chime.
  5. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Reset the SMC

  1. Shut down your Mac
  2. Keep the MagSafe adapter (power cable) plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the built-in keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

After resetting both the NVRAM and SMC test to see if your MBP functions normally/better and let me know how you go.

Other factors to consider

Officially, your MBP is capable of an external resolution up to 2560 x 1600 pixels. So you will need to ensure that you're using the right settings to accommodate that.

  • Hi mate, thanks for the advice. I tried what you said and unfortunately I'm still experiencing the same issue :( – Dallby Mar 26 '17 at 6:07
0

I discovered the problem... turns out that the Macbook couldn't handle the TV running such a high resolution (1080p). I dropped the TV resolution down to 1080i when plugged in to the Macbook and it's all working now. Thanks all for your help, and suggestions.

0

I am having a similar issue while connecting my rMBP15 mid-2012 (same machine...) to an ACER beamer via HDMI.

The fix I found is to deactivate Automatic Graphics Switching in the Energy Saver preference panel, before connecting the HDMI cable. [I actually use gfxCardStatus to monitor which GPU is in use, with more options than the preference panel.]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .