I downloaded the new Xcode 4.2 update yesterday and installed it. The installer shows up in Launchpad as an app, see screenshot below.

Install Xcode Icon

When I hold the mouse button and click the 'X' to delete, it asks me to confirm deletion which I do, then it just stays there.

Delete App Icon

enter image description here

I looked in Console.app and got the message below:

14/10/2011 22:52:20.654 Dock: LaunchPad: Uninstall failed Error Domain=com.apple.uninstalld.request Code=2 "ErrorMissingBundle" UserInfo=0x7fa5ba2e65d0 {Missing bundle string=/Applications/Install Xcode.app} file://localhost/Applications/Install%20Xcode.app/

How do I remove this app?

  • Apple says you should keep that around. You'll need it for MAS to recognize you have it install and update it in the future. But if you don't care about that, open Terminal and enter: sudo rm -R /Applications/Install\ Xcode.app – user10355 Oct 15 '11 at 1:06
  • Ah, I see what you did. You tried to delete from Launchpad. Did you try just going into /Applications from Finder and using Finder to delete it? – user10355 Oct 15 '11 at 4:10

Is there an "Install Xcode" app in /Applications (Specifically /Applications/Install Xcode.app) ?

It looks like the application was removed, and launchpad just has not noticed this fact yet.

  • Yes there is an app there. I also tried reinstalling Xcode by running the installer which worked but I hoped that it would remove the icon and application afterwards but it hasn't – conorgriffin Oct 14 '11 at 23:54
  • Have you tried removing the Install Xcode.app from the Applications folder? – Fake Name Oct 15 '11 at 6:37

I fixed it in the end. I found this program http://chaosspace.de/launchpad-control/ which allows you to add/remove LaunchPad icons. I removed the icon, re-added it and then deleted it which also deleted the application /Applications/Install Xcode.app

User cksum then suggested this might have corrupted my database and I think he is right, however, it looks like Lion recovered it. As he suggested, I browsed the Dock database file with an SQLite viewer and there don't appear to be any problem entries, but in finder I have the following files:

Finder Screenshot

So it looks like Lion identified the corrupt database and my existing one doesn't contain any problematic entries so I think it's fixed.

  • That app is going to corrupt your Launchpad.db, causing duplicates to be entered and your hidden icons to show up again. It's flakey and I'd avoid using it. It works by adding a dash before the item entry in Launchpad's DB (which is just a SQL DB). – user10355 Oct 15 '11 at 1:07
  • Yeah I kinda figured it was a bit of a hack, but I'd tried everything I could think of barring doing an rm -R in Terminal and I thought that would definitely be an unclean removal. So after hiding and unhiding the 'Install Xcode' icon, I removed it from Launchpad the proper way successfully. Time will tell if it causes me a problem I suppose. – conorgriffin Oct 15 '11 at 1:23
  • If you download an SQL viewer (like Base), you can check to see the damage it did. You'll have entries in there prefixed with the dash. Once Launchpad clears out it's cache, those "hidden" items will show up again, but the entries prefixed by the dash will remain. I guess not harmful in and of itself, but certainly not the best thing to have a convoluted DB. You can view (or even delete the DB and start again clean) under ~/Library/Application Support/Dock/ And there's nothing wrong with using rm. It's a standard UNIX command line utility. – user10355 Oct 15 '11 at 4:09
  • Do you have a URL for Base? – conorgriffin Oct 15 '11 at 10:56
  • menial.co.uk/software/base – user10355 Oct 15 '11 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .