1

In finder (OS X 10.12), when browsing the "All My Files" section I see usually 3 instances of each file. Even after deleting the real file the duplicates exist, and Finder tells me they are all the same size.

When I try to move these duplicates to my trash can, it turns into a eject symbol and I cannot delete them.

2

Do you have an external (or network) Time Machine drive set up? If so it is possible that you are seeing the backed up copies of your files.

Open System Preferences and click on the Spotlight icon and then the Privacy tab. Click the "+" button at the bottom of that window and add the Time Machine drive(s). You can then quit out of System preferences.

Something similar was happening to me where I was getting seemingly duplicate items in searches. Excluding my Time Machine drive eliminated that issue.

Just realize that now if you need a file from a Time Machine backup you cant just search for it, you'll have to enter Time Machine to find the file.

0

Relaunch Finder worked for me.

0

This also happened to me. I found another discussion on an apple forum with helpful advice.

Hit cmd option and escape at the same time and it brings up a list of programmes to force quit. Select "Finder" and press "Relaunch" and that should work. It did for me.

  • I have two Time Machine backups, so I think the checked answer makes sense, but I couldn't follow the steps, probably because I had detached the external drive and was not on the LAN. These steps worked for me when I was offline. (Not sure why they are misused, unless someone tried this when Time Machines were still mounted). – benc Jan 2 at 17:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .