1

I'm familiar with how this should work, but for some reason it's steadfastly refusing to cooperate on my system.

I have an old Windows Vista system, which I just use for hosting an old Parallel Port thermal label printer, and I'm trying to connect to it from my macOS Sierra installation. It used to work - but recently broke.

The issue appears to be related to attempting to connect to a file share on the same machine via the Finder: I can see the machine in the Network browser, but when I attempt to connect to it, I get the message that:

'There was a problem connecting to the server "". The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.'

What does work is:

  • Connecting to the file share using Command-K, and entering smb://.local;
  • Connecting to another SMB file share (a Synology NAS) on the network using the Network browser;
  • Other Macs on the same network.

Whilst I can happily use Command-K to connect to the file share, when it comes to connecting to the Windows printer share, I have no choice but to use the Network browser. For the record, I'm attempting to connect to the printer share by:

  • System Preferences > Printers & Scanners;
  • Press the + button;
  • Select Windows;
  • Navigate into 'workgroup', then into - this brings up the same error as before.

I've already tried creating a new user account - same behaviour - and connecting using a Thunderbolt to Ethernet adaptor instead of Wifi - same behaviour.

Any ideas?! Thanks.

0

I am guessing here but it just MIGHT be something to do with the shared printer on your Vista machine. I would be sorely tempted to remove the printer, uninstall the driver, use the printer utility to REALLY remove the driver, reboot and re-add the printer and the printer share.

Windows printer sharing can be flakey, ESPECIALLY if you are sharing it to a Mac. Not sure whether to blame it on the Mac or the PC, but I am leaning towards blaming the PC...

  • Hi Steve - thanks for your input. Sorry - I failed to mention that other users on the network - including those using macOS Sierra - are able to connect to the printer fine. It's just my system that's the problem... – Moisie Mar 21 '17 at 0:21
0

Ahhh - isn't it the way. I've been struggling with this for weeks, and then I find the answer the day after I post it here...

This page helped me: Trouble browsing Windows network printers from Mac

TL;DR:

  • Add printer > Advanced > Windows printer via spoolss
  • Set the URL to smb://(ip-address-here)/Eltron%20Orion%202443 (in my case, the shared printer name being 'Eltron Orion 2443');
  • Then when I came to print, I was prompted for authentication - and bingo!

Hope that helps someone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .