2

I don't normally move my laptop. Today I made an exception and took it to a friend's house. Once I've returned home, I was no longer able to connect to the Internet. The browser says: "Server not found" and the system clock does not show the correct time. I don't use WiFi, I connect to the Internet using a physical connection. When I connect the same cable to my desktop Mac, I have no trouble connecting to the Internet, so the problem is not with my router or Internet service provider. I restarted my laptop in Internet recovery mode and was able to browse the Internet while in that mode. Please help me restore Internet connectivity.

MacBook Pro macOS Sierra Version 10.12.3

  • When the ethernet cable is plugged in, what does "System Preferences" -> "Network" show for the ehternet connection? – j-beda Mar 18 '17 at 20:29
  • @j-beda: Thanks for replying. I'm currently chatting with an Apple supports representative. Hope she is able to help me. – Evan Aad Mar 18 '17 at 21:01
  • @j-beda: I contacted Apple support. They chatted with me for over two hours. I spoke with three different people. In the end, the issue was resolved. They had me delete the Ethernet entry in System Preferences -> Network, add a new Ethernet entry, and then reset the SCM as described in this article ("Reset the SMC on Mac notebook computers"). This fixed it. – Evan Aad Mar 18 '17 at 23:38
  • @EvanAad We're glad you got this resolved. Could you please add this as an answer and then accept it so that others who find your post can also benefit? Thanks! :) – Monomeeth Dec 15 '18 at 2:59
  • @Monomeeth: Done. – Evan Aad Dec 15 '18 at 7:07
1

OP here. The issue was resolved with the help of an Apple support representative back in March 2017. The solution was to delete the Ethernet entry in System Preferences -> Network, add a new Ethernet entry, and then reset the SCM as described in this article ("Reset the SMC on Mac notebook computers").

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .