4

I have an external BT controller with my MacPro 3,1. (I want it to support BT 4.0 which the built-in does not). A few months ago, somehow BT was no longer enabled at boot-time. How do I re-enable it? Mac OS 10.11.6.

The nvram settings are as follows:

EFIBluetoothDelay   %b8%0b
IONVRAM-FORCESYNCNOW-PROPERTY   boot-args
SystemAudioVolume   4
SystemAudioVolumeDB %f4
bluetoothActiveControllerInfo   %01%00%12%0a%01%00%00%00 =%00%1a}%daq%13
bluetoothHostControllerSwitchBehavior   always
bluetoothInternalControllerInfo %06%82%ac%05%00%00 ]%00#l%bd%e5_
boot-args   
boot-gamma  m%1e%00%00%d9V%00%00%00%83%08%00%b6%00%00%00%00%00%00%00%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7
efi-boot-device <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>EA7AF82F-7F7A-44D1-BEB0-35F3A2712898</string></dict></dict><key>BLLastBSDName</key><string>disk0s2</string></dict></array>%00
efi-boot-device-data    %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%02%1f%03%12%0a%00%01%00%00%00%00%00%04%01*%00%02%00%00%00(@%06%00%00%00%00%00%90`f%1d%00%00%00%00/%f8z%eaz%7f%d1D%be%b05%f3%a2q(%98%02%02%7f%ff%04%00
fmm-computer-name   Otheus%e2%80%99 Mac Pro
prev-lang:kbd   en:2
4
  • 1
    Have you tried booting into Safe Mode and then restarting your Mac Pro to see if it makes a difference? Also, can clarify the model of external BT controller you're using and how long it's been working fine for? Finally, did this problem coincide with anything else (e.g. software update, new hardware, etc)?
    – Monomeeth
    Mar 21, 2017 at 23:39
  • Are you still having this issue? If so, any update or extra info you can provide since my last comment?
    – Monomeeth
    Mar 27, 2017 at 0:32
  • sorry about delay. issue persists,. I cannot say when problem began. possibly after video card upgrade. typically after reboot, system would use builtin BT controller. Had to switch using BT explorer, whicj often acts funny amd sometimes doesnt set pram correvtly.
    – Otheus
    Mar 28, 2017 at 20:15
  • What's your external BT controller? And, do you know what the settings in PRAM should be? (you say BT explorer doesn't set it properly)
    – Monomeeth
    Mar 28, 2017 at 21:04

2 Answers 2

2
+25

Try a PRAM reset if you think NVRAM could be causing this. Other than that you can create a new admin user in System Preferences > Users & Groups and reboot into that. It won't fix the issue but if it doesn't happen you can be sure a setting or application in your profile is causing it. If it persists it could be NVRAM or even a software update.

2
2

Unplug the adapter and plug it back in.

On my older Mac, in order to use macID, I had an LE dongle that has a blue indicator LED that would turn on (meaning it had power) but it would not broadcast BTLE until being removed and plugged back in.

Because of the design of macOS, it only recognizes the adapter after being removed and plugged back in for some unknown reason.

Unfortunately, after looking for solutions for a long time, this was the only one that worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .