5

Terminal app in Sierra keeps crashing so I switched to iTerm. But iTerm tabs behave weirdly. Whatever I do in one tab automatically replicates across all open tabs! Am I missing some setting to turn this off? Please help.

Attached a gif showing that I open 1 file in tab 3, upon switching to tabs 1, 2 I see the same file open.

enter image description here

2 Answers 2

2

Watching your tab titles in the GIF, it looks like you're using Move Tab Left, which is moving the tab you opened vim in to the left.

What you need is Select Previous Tab to change tabs, or even CMD-1 to move to tab1, etc.

7

In the Menu: Shell > Broadcast Input > Send Input to Current Session Only

3
  • this setting is what is selected. please see my screenshot i.stack.imgur.com/6lVp4.jpg. In Spite of this setting being "send input to current session only" I see this behavior. Please advise. Mar 18, 2017 at 10:21
  • Whai if you select Send to all sessions and then rollback to Current Session Only?
    – gmc
    Mar 18, 2017 at 15:10
  • This did not work for me.
    – mjuopperi
    Jun 19, 2019 at 8:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .