6

I synchronise my contacts over iCloud. On the web (iCloud.com) I have more than 1'000 contacts which are synchronised on my Mac Mini at home, on my iPhone and iPad.

I then have a MacBook pro where only ~200 of them are synchronised:

  • If I switch off "Contacts" in the iCloud preferences and I switch it on again, I re-get the same ~200 contacts
  • If I create a new one on the MacBook it is correctly synchronised on all the other deviced
  • If I crate a new contact on iCloud.com it gets synchronised on all the devices (even the MacBook)
  • If I modify a contact on iCloud.com it then gets synchronised on the MacBook (but only if modified)

How can I force a re-sync?

Edit

Although the problem is similar to Force contacts to sync with iCloud right now the solutions provided do not help:

  • Closing and reopeningdoes not solve the problem
  • Re-booting does not solve the problem
  • Disabling and re-enabling iCloud does not solve the problem (see above)
  • Adding a contact does not solve the problem (see examples above)
  • Signing in and out does not solve the problem (see above)
  • Dragging the contacts to the local store and back to iCloud clearly does not work as I don't have the contacts on my mac
  • All the other hints refer to iOS

Edit 2

I am not able to export/import (drag in/out) the contacts to solve the problem as in the proposed duplicate. I have only 200 contacts on my Mac. The full content is in iCloud.

Edit 3

I tried the suggestion in the comments and created a group on the Mac Mini with alle the contacts. The group is synchronised to iCloud but in the MacBook I get it with the same ~200 contacts that where previously synchronised.

Edit 4

I also exported all the contacts on the Mac Mini and re-imported them. Almost no effect (on the MacBook pro I habe now 219 contacts). A couple (?) more, but still far from the >1000.

  • 1
    Possible duplicate of Force contacts to sync with iCloud right now – fsb Mar 17 '17 at 14:26
  • 1
    Would you be able to export/reimport all your contacts using your Mac Mini? If I understand you correctly, the Mac Mini is syncing correctly. – user11633 Mar 17 '17 at 15:27
  • 1
    Since modifying a contact causes it to sync to the MacBook, it might be possible to drag all your contacts into a group, then taking them out. I don’t know if changing groups would be enough or if each contact needs an actual field update. – user11633 Mar 17 '17 at 15:37
  • 2
    Really odd situation. Your MacBook Pro must has a corrupted Contacts database that’s preventing contacts from being displayed until they’re “rebuilt” by updating their entry. You could wipe your local files, but be prepared to restore in case something goes wrong. There are files under Application Support/Address Book, Caches/com.apple.AddressBookSourceSync, Saved Application State/com.apple.AddressBook.savedState and Preferences/com.apple.AddressBook.plist (all under ~/Library). Delete these while signed out of iCloud. Once that’s done, reboot and sign back in to iCloud. – user11633 Mar 19 '17 at 20:47
  • 2
    @Phong. Seems to slowly work. I have now ~400 contacts ... Please post your last comment as an answer so that I can accept it. – Matteo Mar 21 '17 at 9:45
6

Your MacBook Pro must have a corrupted Contacts database.

Signing out and back in to iCloud isn’t fixing anything because your MacBook Pro is reusing its local database, and thinking that everything is up to date. Updating a contact is what “rebuilds” its entry, allowing it to be displayed.

Try wiping your local cache to force your MacBook Pro to re-download all of your contacts from iCloud.

  1. Sign out of iCloud.
  2. Delete ~/Library/Application Support/AddressBook.
  3. Delete ~/Library/Caches/com.apple.AddressBookSourceSync.
  4. Delete ~/Library/Saved Application State/com.apple.AddressBook.savedState.
  5. Delete ~/Library/Preferences/com.apple.AddressBook.plist.
  6. Restart your MacBook Pro.
  7. Sign back into iCloud.

Your contacts should all download fresh from iCloud.

(Note: Steps 2 & 3 are really the crucial ones, but the Contacts.app doesn’t have much in the way of preferences, so might as well be thorough.)

You must log in to answer this question.

protected by Community Aug 10 '18 at 23:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .