1

I am using macOS Sierra 10.12.3

I'm new to Macs and just encountered the problem, that Macs don't open ntfs formatted external drives by default. Well, since I am not new to linux, I just added the following line to /etc/fstab:

UUID=xxx-xxx-xx none ntfs rw,auto,nobrowse

Unfortunatly that did not work. After I plugged in the drive. So I tried to mount it manually by: mount -a That gave me the error message, that none does not exist. So I created a folder /Volumes/external and changed fstab to:

UUID=xxx-xxx-xx /Volumes/external ntfs rw,auto,nobrowse

That worked! GREAT!

BUT as soon as I plugged out the drive, the folder was deleted automatically. And after a new plugin of the drive, it could not mount, because the folder was missing.

So my main question is: How can I configure write-enabled auto-mounting of NTFS drives?

  • Have you tried using the path that the Finder creates when you plug in the drive when there's no entry in /etc/fstab instead of /Volumes/external? – jaume Mar 17 '17 at 10:38
  • No, I haven't. Good hint. I will try it out this evening and report. Thanks! – Timo Mar 17 '17 at 11:03

You must log in to answer this question.

Browse other questions tagged .