0

When I run launchctl to load/start the plist with the following content:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>com.web_blocker</string>
    <key>ProgramArguments</key>
    <array>
        <string>/Applications/Python 3.6</string>
        <string>/Users/michaelcunningham/Desktop/website_blocker.py</string>
    </array>
    <key>StartInterval</key>
    <integer>60</integer>
    <key>RunAtLoad</key>
</dict>
</plist>

I get the error "invalid property list". How can I resolve this issue?

  • i added <true/> but it still comes back with the same error – epictrojan Mar 16 '17 at 15:28
  • I copied your plist, added the <true/> line, saved it to my LaunchAgents folder and loaded the plist with launchctl load ~/Library/LaunchAgents/com.web_blocker.plist without an error message - even though I neither have a folder /Applications/Python 3.6 nor a user michaelcunningham or a website_blocker.py! – klanomath Mar 16 '17 at 17:08
  • maybe it has to do with LaunchAgents folder? i have a couple. how can i ensure it goes into the correct folder? i still get the same error – epictrojan Mar 16 '17 at 22:55
1

Your plist is missing at least the line <true/> (or <false/>) after the line <key>RunAtLoad</key>.

The line <string>/Applications/Python 3.6</string> is useless because this is just a folder but no app/binary. Your Python script may work nevertheless, provided the shebang is set properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .