0

Firefox was refusing to launch on my MacOS El Capitan. Console gave me the following message:

com.apple.xpc.launchd: (org.mozilla.firefox.320352[6799]) Service exited with abnormal code: 1

In the course of troubleshooting this, I must have happened upon the Profile Manager. While attempting to create a new profile in the standard folder (~/Library/Application Support/Firefox/Profiles/), I saw the following error:

error

I had the Profile Manger save the profile to the Desktop, and now Firefox works. But I'd like to get it working normally, i.e., saving the profile to the standard folder—largely because I am having issues in other applications which might also be related to screwy permissions.

The permissions on the Profiles folder are: rwx--------- (700).

Any clues on how I can have Firefox store its profiles in the standard folder?

  • Could you try chmod 755 Profiles? That’s what the permissions look like on my system. – user11633 Mar 16 '17 at 0:35
  • 1
    @Phong That probably would have worked. My solution, included as an answer below, is more general, probably applying 755 permissions recursively to the whole user folder, which may have been overkill. We'll see. – Garrigus Carraig Mar 16 '17 at 17:28
0

This issue, as well as issues I was having with iTunes and f.lux, were resolved by resetting permissions on the home folder. Before doing this, I had upgraded to Sierra from El Capitan. So the reset process I used is for Sierra. It's included below, and the original can be found here:

Reset permissions

If the issue occurred after changing the permissions of items in your home folder, follow these steps to reset the permissions:

  1. From the Finder menu bar, choose Go > Home. Your home folder opens.
  2. Choose File > Get Info. An Info window for your home folder opens.
  3. If the “Sharing & Permissions” section at the bottom of the window isn't open, click the triangle in that section to open it.
  4. If the Lock button at the bottom of the window shows a closed lock lock, click the lock and enter an administrator name and password.
  5. Click the Action menu in the bottom corner of the window, then choose “Apply to enclosed items.” Click OK to confirm the action. A progress bar appears at the top of the window.
  6. When the progress bar completes, open the Terminal app from the Utilities folder of your Applications folder.
  7. Paste or type this command in Terminal, then press Return:

    diskutil resetUserPermissions / `id -u`
    

    On U.S. keyboards, the ` character is just above the Tab key. After entering the diskutil command, if Terminal says that permissions reset on user home directory failed (error -69841), enter chflags -R nouchg ~, then enter the diskutil command again.

  8. When the process completes, quit Terminal.

I discovered a quite different process for El Capitan on The Mac Observer OS X: Repair Home Folder Permissions, which I have not tried, and so cannot speak to its efficacy.

  • I searched at least ten minutes for documentation of the diskutil resetUserPermissions command and found nothing. – Garrigus Carraig Mar 16 '17 at 17:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .