0

We have two Apple computers next to each other on one desk: a Mac Mini and a 27” iMac (both late 2012) and both running macOS Sierra 10.12.3.

We have a Wi-Fi router in the next room (about 9 metres away from furthest machine). It's a Virgin Super Hub 2ac.

The iMac connects on 5G and works well – it rarely drops out and is quite fast (DL 49.37 Mb/S).

The Mac Mini connects on 2G (will not connect on 5G – it almost immediately defaults to 2G). It is often (but not always) painfully slow in connecting to websites (particularly in the evening). It makes it almost impossible to use. DL speed this morning was 18.96Mb/s.

This is very frustrating. I have spoken several times to both Apple and Virgin. Both have seemed helpful at the time. Virgin have adjusted some settings remotely which seemed to work initially but problem returned. Virgin claims the Mac Mini is not able to pick up the 5g signal because of its specification.

Is this true? Do we have to buy a new computer to replace the Mini?

  • Have you tried a cabled connection for the Mini? – lhf Mar 15 '17 at 10:28
  • Does the Mac Mini still have a slow connection when the iMac is powered off? Does the iMac show similar slowness if you connect it to the 2.4 GHz channel instead of the 5 GHz channel? – Merlin Mar 16 '17 at 6:20
1

Virgin claim the Mini is not able to pick up 5g signal because of its specification. Is this true?

No, this is not true. Both the Late-2012 iMac and Late 2012 Mac Mini have the same specifications in terms of Wi-Fi.

Do we have to buy a new computer to replace the Mini?

No. If it was me, I would share the internet connection from the iMac to the Mac Mini via an ethernet cable. This should be easy enough since they're on the same desk.

To do this:

  • Connect the iMac and Mac Mini via an ethernet cable
  • On the iMac:

    • go to System Preferences > Sharing
    • in the service pane on the left, highlight Internet Sharing
    • in the Share Your Connection From drop-down select Wi-Fi
    • in the To computers from list tick the Ethernet port
    • in the service pane on the left, tick the Internet Sharing checkbox
  • To ensure the Mac Mini is using this connection instead of the 2g one, you can either switch Wi-Fi off or choose to change the preference order of your connections in the Network preferences pane so that Ethernet is listed ahead of Wi-Fi.

Once you've set this up, you should have a fairly good connection on the Mac Mini.

In terms of why the iMac is getting the 5g signal and the Mac Mini isn't, it could be as simple as the iMac causing some sort of obstruction (especially if the iMac is the one closer to the Wi-Fi router).

However, I have found more often than not many devices will connect to a 2g network in preference to a 5g network. While 5g provides a faster connection, it isn't as robust as a 2g connection. So, if distance is an issue (not likely in your case) or if there are physical obstructions impacting the signal, a 2g network is often better.

1

If you still have doubt that Mac Mini supports 5 Ghz or not, you can check system configuration by yourself (It will help you to get back to Virgin with proof).

  1. Click on the Apple icon.
  2. Select "About this mac"
  3. Select "System Report"
  4. Select "Wi-Fi" under "Network" field.
  5. In the Wi-Fi, under Interface (en0) it will show you "Supported PHY Modes" ans "Supported Channel". Like below,

    Supported PHY Modes: 802.11 a/b/g/n/ac Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 144, 149, 153, 157, 161, 165

If it supports only 2.4 GHz, it will show 802.11 b/g/n under "Supported PHY Modes" and 2.4 Ghz channels (1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13) under "Supported Channels".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .