17

I tried control+shift+power button as well as command+shift+power button. Neither seem to work.

16

You can set up a hot corner for screen saver, and have the security settings to require your password immediately after the screen saver starts. This means when you go to leave the computer, you just move the mouse to a specified corner of the screen and BAM it's locked.

First, you would open System Preferences, and then go to "Desktop & Screen saver". Then click the "Screen saver" tab in the top middle.

Click on the "Hot Corners" button in the bottom right. Here, you can select a corner of the screen to attach an action to.

I'd suggest one of the bottom corners for this. Since there are menu buttons in both top corners on a Mac, you don't want to accidentally trigger the screen saver every time you want to open the Apple menu or Notification Centre. I have the bottom left corner on my set to display sleep, but you can choose "Start screen saver" for a corner as well.

Second, you will need to go back to the main System Preferences page, and click "Security & Privacy". In the General Tab, you can tick the box for "Require password X minutes after sleep or screen saver starts" The "X minutes" bit is a drop down box and you can choose from Immediately or 5 seconds, up to 8 hours.

Now whenever you want to lock the screen, just move the mouse right into the corner you selected before leaving the computer and when someone else tries to use the computer, it will ask for your password.

Edit Jan 5th: As of High Sierra (10.13), there is an option in the Apple Menu to lock the screen, which does not cause the system to sleep. Works a charm. You can also press the Control, Command and Q keys as a shortcut

  • 8
    As of 10.13.4 lock now puts my mac to sleep again. It worked before that. I have the lock icon in my touchbar. Would appreciate if anyone had any fix for that because it really messes up my start build, lock, get coffee flow since it pauses the build when it sleeps until I get back. – Jilles van Gurp Apr 23 '18 at 12:48
  • 3
    I see the same behavior: lock screen in 10.13.6 puts my MB to sleep. If I haven't misdiagnosed this, it's is not just a problem, it's debilitating, and to be blunt, it's an insane thing for a screenlock to do. Now I have to VNC into any remote machine unless I want these terminal jobs to freeze whenever I lock my screen manually. – Randy Nov 16 '18 at 16:24
  • 2
    I see the same behaviour as well. Whenever I lock the screen, the MBP inevitably goes to sleep after a short while. The MBP also goes to sleep shortly after the screen saver has been activated (using a hot corner). There doesn't seem to be an option to keep the MBP awake on the lock screen or in screen saver mode any longer. As @JillesvanGurp mentioned, this is super annoying as it screws up the developer workflow, and it causes issue with a dual external monitor setup through a docking station (ref. separate question). Has anyone found a solution/workaround for this problem? – Leif Feb 11 at 12:21
  • Here is a separate/related question, specific to the dual external monitor setup I mentioned in my previous comment: apple.stackexchange.com/questions/350902/… – Leif Feb 11 at 12:25
6

Just follow these steps to lock the screen on macOS.

  1. In Spotlight ( + Space) search for Keychain Access
  2. In Keychain Access, select Preferences... from the first menu ( + ,)
  3. Check Show keychain status in menu bar. This will show a lock in your Menu Bar with an option Lock Screen

    Add a custom shortcut to lock the screen

    • System Preferences > Keyboard > Shortcuts
    • In the App Shortcuts section, add a new item for All Applications with the Menu Title of Lock Screen and a Keyboard shortcut that you like.
  • I'm not sure I understand your last sentence. How do either of the changes you suggest affect the ability to use ⌃⇧power such that they are then able to use that shortcut? – grg Mar 15 '17 at 8:09
  • In High Sierra, the option "Show keychain status in menu bar" is not in the Keychain Access' Preferences at all, but I see Lock Screen under the apple menu since the upgrade to High Sierra (at least I think that caused it to appear). I do use TouchID, maybe they added this option automatically now. – Dalibor Filus Oct 30 '17 at 13:16
2

I use the keyboard shortcut Control Shift Eject.

This will immediately invoke the screensaver. You will have to enable the Require Password immediately after sleep or screen saver begins in the System Preferences -> Security preferences.

  • I have no eject button on my keyboard.. – sudhanva Aug 23 '17 at 3:18
  • In newer macs it is the power button – Luis Belloch Sep 27 '17 at 11:07
  • 1
    many of the recent macs don't a power button either. The shortcut method is best for that. – Ejoso Apr 12 '18 at 19:01
1

Open terminal, type open -a ScreenSaverEngine

0

What I ended up doing is to put a Screen Saver item to my TouchBar and configured the system in Security & Privacy to require a password after a short period of time.

Security & Privacy

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .