1

My MacBook Pro mid-2012 has been acting up lately. A year ago I replaced the original hard drive with a Samsung SSD 850 EVO 1TB, and everything was fine. Then the SSD became corrupted and was exchanged under warranty. Since installing the second SSD I've installed a fresh copy of the latest macOS Sierra on a single 1TB partition and have been having issues ever since.

The symptoms are:

What I have done:

  • Reset the NVRAM. Result: no significant change in behaviour
  • Reset the SMC. Result: no change in behaviour
  • Did the Disk Utility trick where I modified the size of my partition, then set it back to a single 1TB partition again, in order to have Disk Utility rewrite the partition map (or something). Result: now it doesn't constantly fails when I close and reopen the lid. Although it may have been the result of the next point.
  • Changed the energy settings to default (I have a script I run when I setup a new computer, and it includes some non default power management settings). Result: see previous point.

Questions:

  • Does this seem like a hardware failure or a software failure?
  • What can I do to be sure either way?
  • Any suggestions on how I can reliably fix this?

I have several full backups of my data, so I can try virtually anything. I'm determined to find out how to fix this. Perhaps installing a stock version of macOS Sierra and not changing anything at all, and using it like this for a few days could help me figure things out in more detail?

  • Have installed trim enabler and set trim enabled? SSD is set as startup disk in System Preferences? Boot it into Target disk mode and connect to another mac and run Disk Utilty old version and run First Aid? Or boot off a system on an external drive and repair SSD? – MacOptimist Mar 14 '17 at 9:46
  • Since you have everything backed up, I would try installing El Cap. Sierra has had numerous glitches and it's wise to eliminate it as a potential cause. If it happens in El Cap, then it's most definitely not software. – Allan Mar 14 '17 at 11:54
  • Good point @monomeeth, I'll try that and update the question with the results. – Jean-Étienne Mar 15 '17 at 3:05
  • Rings a bell. What is Trim Enabler? Can you explain a bit more? – Jean-Étienne Mar 15 '17 at 3:07
2

Some Mid-2012 MBPs had an issue with the Hard Drive Flex cable that could cause similar issues (at least as far as the Booting to a Folder with a Question Mark), so I might be worth calling Apple or heading to an Apple Store to have them have a look.

If it is one of those ones, you may get a repair for free for it. I gotta stress though, it isn't ALL mid-2012s, just some of them. Mine wasn't one of them (I had permanent "No Hard Drive Detected" but the tech I saw initially thought it was, hence me knowing anything at all about it).

If it is the cable that is faulty, it didn't cost a lot out of warranty anyway, although if you are getting the odd Prohibitory symbol, then you may want to reformat the drive and reinstall OS X anyway to get rid of any filesystem problems that would still be there beyond hardware

  • Oh yeah, they won't care about it being a non Apple drive either, so long as you didn't damage anything inside while putting it in, but Evo's apparently set of Apple's diagnostics as the drive failing because they sometimes use SMART stats weirdly (my 840 causes the tests they use after repairs to fail the drive itself once the cable was sorted – FreelancerJ Mar 14 '17 at 11:43
  • That would be the cheapest hardware fix. I'll call an Apple Store and see with them. Thanks for the suggestion. – Jean-Étienne Mar 15 '17 at 3:06
  • With any luck, you'll get it for free! :) But yeah, if it's not one, at least its not too costly – FreelancerJ Mar 15 '17 at 6:59
  • This was it. I had it changed for free by Apple and now my computer runs fast and reliably as it use to. – Jean-Étienne Jun 18 '17 at 3:08
1

Two things you don't seem to have tried as troubleshooting steps are to try booting your MBP into Safe Mode and also running Hardware Diagnostics.

Boot into Safe Mode

Follow these steps boot your MBP into Safe Mode:

  1. Fully shut down your MBP
  2. Restart your MBP
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. could you boot your Mac okay, are you still experiencing the same issues, etc)
  6. Exit Safe Mode and restart your MBP as normal
  7. Again, take a note of what happens (i.e. could you boot your Mac okay, are you still experiencing the same issues, etc)

If the above seems to make no difference, then see below to run Apple Diagnostics.

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your MBP
  2. Restart your MBP
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Regardless, take a note of what happens and let me know how you went.

  • I think I tried to boot in safe mode. Can't remember the results. I'll try again. – Jean-Étienne Mar 15 '17 at 3:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .