I came into the office today with my MacBook Pro and usually my Wi-Fi automatically connects to the network, but instead it is constantly searching.

If I go to System Preferences > Network > Wi-Fi, there is a solid yellow circle and the text reads "Wi-Fi does not have an IP address and cannot connect to the Internet".

I've tried turning off Wi-Fi and restarting the computer but neither has worked.

  • Is there not anyone in your office responsible for maintaining the computers and network that you can have look at your issue? Mar 13, 2017 at 15:15
  • @user3439894 There is, I wanted to see if I could solve the problem myself first.
    – nukenine
    Mar 14, 2017 at 17:38

4 Answers 4


In the Network Preferences, click "Advanced ..." and remove the WiFi network from the 'Preferred Networks'. This will make macOS forget the network, after which you can attempt to connect again. macOS will build up the connection 'from scratch' and won't rely on any cached settings. I have to use the same trick once in a while for our corporate WiFi network.

  • Did not seem to work for me, I did manage to get onto another network that we have in the office, but the original one did not work.
    – nukenine
    Mar 13, 2017 at 15:13

As a workaround you can set IP address manually

Using DHCP with manual address


If toggle Wi-Fi Power and removing preferred Network doesn't work then try "Renew DHCP lease".

After the connection.

  1. Goto System Preference -> Network -> Select Wi-Fi -> Advanced -> TCP/IP
  2. Click on "Renew DHCP lease" and apply.

It works sometime.

If this also not works you can try with valid Static IP (add DNS also, manually)


There are 4 main steps for WiFi to work and you’ve passed the first hurdle.

  1. The radios establish a two way link on the SSID - agreeing on channel, encryption, and what if any password your client needs to be let on.
  2. The computer optionally asks for an address to be assigned (DHCP request) over the working radio connection.
  3. The receiving access point will either answer that request or broadcast / assign it to another device to handle.
  4. The response is delivered to your Mac which needs to configure itself for the DNS/DHCP address and subnet assigned.

The last three steps could be combined into one if you know all the settings and set up your network automatically. Since you have the message “does not have an address” one of the three things that happen externally has failed so you’ll need to manually configure the network settings or ask for help.

Since the radio is up, you could run a packet capture tool like sudo tcpdump -i en0 with en0 possibly being another number on your system and look for those DHCP broadcast or ARP requests and figure out what network address might be available - but that borders on setting up the network so it’s really best to not potentially break the network for everyone if you assign yourself an address that was reserved or is in use already.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .