1

I have two Macs, and iPhone and iPad. I have setup iCloud and Google accounts with Calendars on all of them. Its works everywhere, syncs and loads up great, except for 1 Mac.

One of them just won't sync any calendars, be it iCloud or Google. I enable the Google Account and then I just get no calendars download and appear.

Any help much appreciated, thanks.

1

On your Mac that isn't syncing, go to System Preferences > Internet Accounts. From the list of accounts in the left column of the screen, select the account that isn't syncing in. Make sure that "Calendars" is checked.

enter image description here

Next, open your Calendars app. Click "Calendar" (next to the Apple icon in the menu bar) > Preferences (NOTE: Clicking "Accounts" instead of "Preferences" will just send you back to System Preferences > Internet Accounts). In the Preferences pane, click "Accounts". Select the account that wasn't syncing. Then make sure that "Enable this account" is checked.

enter image description here

If the calendar still isn't appearing, make sure that you're not hiding the calendar. There is a toggle button in the Calendar app that hides or shows the list of calendars available to display. If you cannot see a list of calendars on the left column of your Calendar app, then click the "Calendars" button in the top left corner of your Calendar app. This will display a list of calendars on the left side of the app. Make sure that your missing calendars are checked. Unchecked calendars will not show up in your calendar view.

enter image description here

  • Thanks but this doesn't resolve anything. These are basic instructions for displaying your Calendars, not a resolution for ones that are not syncing as in my case. – Josh Kahane Mar 14 '17 at 13:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .