1

My MacBook won't display anything connected through an USB-C Digital AV Multiport Adapter to HDMI display. I have tried with many (Dell, Samsung, Acer, Iyama, LG, from the local store) external displays.

Sometimes (after a restart, with SMC reset) it works for 5 seconds and suddenly stops. It does not even show the external display in the preferences.

Do you know how to fix it?

Hardware details:

  • USB-C Digital AV Multiport Adapter from Apple (MJ1K2ZM/A)
  • MacBook Pro (13-inch, 2016, Two Thunderbolt 3 ports)
  • 2,4 GHz Intel Core i7
  • 16 GB 1867 MHz LPDDR3
  • Intel Iris Graphics 540 1536 MB

I have noticed one thing - when I disconnect the HDMI cable the display says "No HDMI Cable" when I connect it back it says "Entering Power Save Mode".

  • Did you make sure everything is fully plugged in? Try playing with each of the connections. Also curious what your display settings say. – JBallin Mar 12 '17 at 2:15
  • @JBallin I have played with all the connections with many displays. How should I check my display settings? – Etam Mar 12 '17 at 9:37
  • Maybe go to Apple Store so somebody can look at it in person. Also maybe try another adapter/hdmi cable. – JBallin Mar 12 '17 at 18:33
  • @JBallin I will do it tomorrow :(. – Etam Mar 12 '17 at 19:29
1

I had to replace the adapter. It seems the one I was using was broken. Now everything is fine and the display displays :).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .