4

When I create or edit a Smart Mailbox and I want to add filter Message is not in mailbox it works fine for all my e-mail accounts except iCloud.

So, if I add such filter in some Smart Mailbox settings and would try to add some mailbox from my iCloud account, it will do that, but it will reset it after I press OK - when I open settings for this Smart Mailbox again, I see the following:

enter image description here

As you can see, instead of my chosen mailbox that I wanted to exclude there is No mailbox selected. And of course this filter doesn't work.

But again, if I add any mailbox from any other account beside iCloud to this filter, it works fine, so the issue is only with iCloud mailboxes.

Do you know, why is that and how to fix this?

  • 1
    I'm having the same issue. – Greg R. Oct 31 '17 at 12:15
  • Crap me too! I even posted another question about it just a few weeks ago, couldn't find any other mention of it until I was pointed here today. apple.stackexchange.com/questions/299870/… – Jonathan van Clute Oct 31 '17 at 16:29
  • 1
    Apparently this issue deserves a bug-report to Apple since nobody has been able to solve it yet. I'll submit it then. – retif Oct 31 '17 at 17:02
  • 1
    I just reported it too as this is driving me more insane every damn day. – Jonathan van Clute Nov 9 '17 at 4:58
2

I had the same problem and I found a solution here luckily after searching like crazy. The problem was, that I used my Gmail account as my Apple ID, so mail got confused. After I deactivated mail in my iCloud account settings, it was working fine. This is obviously only a solution if you don't use both accounts. Anyway, maybe it helps someone:

And here's the solution, or rather the explanation for the problem: If you're using your gmail Adress as your apple-id (and therefore as your login credentials for your iCloud account) Apple Mail seems to get confused. Simply change your iCloud Username to something else and your good to go.

1

I don't know how to fix it, but I have a workaround. Create a smart mailbox (we'll call it Workaround), set it to "message is in mailbox" and then select the iCloud mailbox you want. Then create a second smart mailbox and set it to "message is not in mailbox" - "Workaround". This seems to work for me on High Sierra. Now you have an extra smart mailbox, but it gets the job done.

  • iCloud mailbox disappears from the first one as well (Workaround, in your case), so it anyway shows "No mailbox selected" already on that step :) – retif Nov 23 '17 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .